aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Apache-DBI/Makefile')
-rw-r--r--www/p5-Apache-DBI/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index ffc362998286..c9226c25b9fc 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Apache-DBI
-PORTVERSION= 0.89
+PORTVERSION= 0.91
CATEGORIES= www databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -15,11 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= DBI persistent connection, authentication and authorization
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Bundle/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Apache::DBI.3 Apache::AuthDBI.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>