aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CGI-Ex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CGI-Ex/Makefile')
-rw-r--r--www/p5-CGI-Ex/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-CGI-Ex/Makefile b/www/p5-CGI-Ex/Makefile
new file mode 100644
index 000000000000..0cfb36ccb8ea
--- /dev/null
+++ b/www/p5-CGI-Ex/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-CGI-Ex
+# Date created: 2006-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Ex
+PORTVERSION= 2.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= CGI utility suite - makes powerful application writing fun and easy
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Ex.3 CGI::Ex::App.3 CGI::Ex::Auth.3 CGI::Ex::Conf.3 \
+ CGI::Ex::Die.3 CGI::Ex::Dump.3 CGI::Ex::Fill.3 \
+ CGI::Ex::JSONDump.3 CGI::Ex::Template.3 CGI::Ex::Validate.3
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in app benchmark conf_path_1 conf_path_3 devel
+ ${MKDIR} ${EXAMPLESDIR}/${i}
+.endfor
+ ${CP} -R ${WRKSRC}/samples/* ${EXAMPLESDIR}
+
+.include <bsd.port.mk>