aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Data-Validate-URI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Data-Validate-URI/Makefile')
-rw-r--r--www/p5-Data-Validate-URI/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-Data-Validate-URI/Makefile b/www/p5-Data-Validate-URI/Makefile
new file mode 100644
index 000000000000..27f4e0283baf
--- /dev/null
+++ b/www/p5-Data-Validate-URI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-Data-Validate-URI
+# Date created: 02 January 2008
+# Whom: Tuc <freebsd-ports@t-b-o-h.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Validate-URI
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd-ports@t-b-o-h.net
+COMMENT= Common data validation methods for URIs
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Validate/Domain.pm:${PORTSDIR}/dns/p5-Data-Validate-Domain \
+ ${SITE_PERL}/Data/Validate/IP.pm:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP
+RUN_DEPENDS= ${SITE_PERL}/Data/Validate/Domain.pm:${PORTSDIR}/dns/p5-Data-Validate-Domain \
+ ${SITE_PERL}/Data/Validate/IP.pm:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Validate::URI.3
+
+.include <bsd.port.mk>