aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTTP-Cookies-Mozilla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-HTTP-Cookies-Mozilla/Makefile')
-rw-r--r--www/p5-HTTP-Cookies-Mozilla/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-HTTP-Cookies-Mozilla/Makefile b/www/p5-HTTP-Cookies-Mozilla/Makefile
new file mode 100644
index 000000000000..a53bacb7fb93
--- /dev/null
+++ b/www/p5-HTTP-Cookies-Mozilla/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-HTTP-Cookies-Mozilla
+# Date created: 2006-07-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Cookies-Mozilla
+PORTVERSION= 1.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Cookie storage and management for Mozilla
+
+BUILD_DEPENDS= ${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTTP::Cookies::Mozilla.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from www/p5-libwww
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>