aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Kwiki-UserName/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Kwiki-UserName/Makefile')
-rw-r--r--www/p5-Kwiki-UserName/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-Kwiki-UserName/Makefile b/www/p5-Kwiki-UserName/Makefile
new file mode 100644
index 000000000000..38ff4aa74d04
--- /dev/null
+++ b/www/p5-Kwiki-UserName/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Kwiki-UserName
+# Date created: Jul 24 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-UserName
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Kwiki User Name Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki \
+ ${SITE_PERL}/Kwiki/UserPreferences.pm:${PORTSDIR}/www/p5-Kwiki-UserPreferences
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::UserName.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>