aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Net-GeoPlanet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Net-GeoPlanet/Makefile')
-rw-r--r--www/p5-Net-GeoPlanet/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-Net-GeoPlanet/Makefile b/www/p5-Net-GeoPlanet/Makefile
new file mode 100644
index 000000000000..80c6c634af64
--- /dev/null
+++ b/www/p5-Net-GeoPlanet/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-GeoPlanet
+# Date created: 2008-08-05
+# Whom: Steven Kreuzer <skreuzer@exit2shell.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-GeoPlanet
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@exit2shell.com
+COMMENT= Access Yahoo's GeoPlanet location service
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Test-Simple>=0.74:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::GeoPlanet.3
+
+.include <bsd.port.mk>