aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Squatting/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Squatting/Makefile')
-rw-r--r--www/p5-Squatting/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-Squatting/Makefile b/www/p5-Squatting/Makefile
new file mode 100644
index 000000000000..6295defd5c08
--- /dev/null
+++ b/www/p5-Squatting/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/p5-Squatting
+# Date created: 07 July 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Squatting
+PORTVERSION= 0.40
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BE/BEPPU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= A Camping-inspired Web Microframework for Perl
+
+BUILD_DEPENDS= p5-Continuity>=0.991:${PORTSDIR}/www/p5-Continuity \
+ p5-Class-C3-Componentised>0:${PORTSDIR}/devel/p5-Class-C3-Componentised \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-Shell-Perl>0:${PORTSDIR}/shells/p5-Shell-Perl \
+ p5-JSON-XS>0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN1= squatting.1
+MAN3= Squatting.3 \
+ Squatting::Controller.3 \
+ Squatting::Cookbook.3 \
+ Squatting::Mapper.3 \
+ Squatting::On::Catalyst.3 \
+ Squatting::On::Continuity.3 \
+ Squatting::View.3
+
+.include <bsd.port.mk>