aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-URI-Sequin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-URI-Sequin/Makefile')
-rw-r--r--www/p5-URI-Sequin/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/p5-URI-Sequin/Makefile b/www/p5-URI-Sequin/Makefile
new file mode 100644
index 000000000000..5f513376ca12
--- /dev/null
+++ b/www/p5-URI-Sequin/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-URI-Sequin
+# Date created: 25 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sequin
+PORTVERSION= 1.0
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-URI-
+
+MAINTAINER= tobez@tobez.org
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::Sequin.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e \
+ 's|\);$$|PM=>{q!Sequin.pm!=>q!\$$(INST_LIBDIR)/Sequin.pm!});|' \
+ ${WRKSRC}/Makefile.PL
+
+post-install:
+ @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/URI/Sequin/examples
+ @${INSTALL_DATA} ${WRKSRC}/Example.pl ${WRKSRC}/referer_log?.txt \
+ ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/URI/Sequin/examples
+
+.include <bsd.port.mk>