aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-SourceForge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WWW-SourceForge/Makefile')
-rw-r--r--www/p5-WWW-SourceForge/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-WWW-SourceForge/Makefile b/www/p5-WWW-SourceForge/Makefile
new file mode 100644
index 000000000000..33246f04e1e8
--- /dev/null
+++ b/www/p5-WWW-SourceForge/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-WWW-SourceForge
+# Date created: 21 Oct 2004
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.idv.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-SourceForge
+PORTVERSION= 0.083
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.idv.tw
+COMMENT= Retrieve infromation from SourceForge site
+
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::SourceForge.3 WWW::SourceForge::Project.3
+
+.include <bsd.port.mk>