aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-chklinks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-chklinks/Makefile')
-rw-r--r--www/p5-chklinks/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-chklinks/Makefile b/www/p5-chklinks/Makefile
new file mode 100644
index 000000000000..a1bf3eb143fc
--- /dev/null
+++ b/www/p5-chklinks/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-chklinks
+# Date created: 2007/06/07
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= chklinks
+PORTVERSION= 3.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Locale/IMACAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A non-threaded Perl link checker
+
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+MAN1= chklinks.1
+
+PLIST_FILES= bin/chklinks \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/chklinks/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/chklinks
+
+.include <bsd.port.mk>