aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-libwww/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-libwww/Makefile')
-rw-r--r--www/p5-libwww/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index a62805ac5f3b..bbeffe04193c 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -19,6 +19,14 @@ COMMENT= Perl5 library for WWW access
RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-URI>=0:${PORTSDIR}/net/p5-URI
+OPTIONS= SSL "Enable https support" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_SSL)
+RUN_DEPENDS+= p5-security/p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
+.endif
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= --aliases