aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-WebTest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-WebTest/Makefile')
-rw-r--r--www/py-WebTest/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/py-WebTest/Makefile b/www/py-WebTest/Makefile
index 94dafe36e34a..3b5dc37a3e91 100644
--- a/www/py-WebTest/Makefile
+++ b/www/py-WebTest/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= WebTest
-PORTVERSION= 1.4.0
+PORTVERSION= 2.0.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
http://www.c-s.li/ports/
@@ -13,9 +13,12 @@ COMMENT= Helper to test WSGI applications
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}webob>=1.2:${PORTSDIR}/www/py-webob \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4:${PORTSDIR}/www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}waitress>0:${PORTSDIR}/www/py-waitress
+USE_ZIP= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install