aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-django-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-django-devel/Makefile')
-rw-r--r--www/py-django-devel/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/www/py-django-devel/Makefile b/www/py-django-devel/Makefile
index 853d595e6efe..455db6c4e39f 100644
--- a/www/py-django-devel/Makefile
+++ b/www/py-django-devel/Makefile
@@ -39,27 +39,16 @@ HTMLDOCS_DESC= Install the HTML documentation (requires Sphinx)
PLIST_FILES= man/man1/django-admin.1.gz \
man/man1/gather_profile_stats.1.gz
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPGSQL}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
-.endif
+PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2
+MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MySQLdb
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+FASTCGI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
-.if ${PORT_OPTIONS:MSQLITE}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-.endif
-
-.if ${PORT_OPTIONS:MFASTCGI}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHTMLDOCS}
. if ! ${PORT_OPTIONS:MDOCS}
-IGNORE= you cannot build documentation while setting NOPORTDOCS
+IGNORE= you cannot build documentation with DOCS option disabled
. endif
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
PORTDOCS= *