aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-gandi.cli
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-gandi.cli')
-rw-r--r--www/py-gandi.cli/Makefile6
-rw-r--r--www/py-gandi.cli/distinfo4
-rw-r--r--www/py-gandi.cli/files/patch-setup.py29
3 files changed, 20 insertions, 19 deletions
diff --git a/www/py-gandi.cli/Makefile b/www/py-gandi.cli/Makefile
index 42ecfc529f10..add5783d9198 100644
--- a/www/py-gandi.cli/Makefile
+++ b/www/py-gandi.cli/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gandi.cli
-PORTVERSION= 0.15
+PORTVERSION= 0.16
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}click>=3.0:${PORTSDIR}/devel/py-click \
+ ${PYTHON_PKGNAMEPREFIX}click>=3.1:${PORTSDIR}/devel/py-click \
${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
${PYTHON_PKGNAMEPREFIX}ipy>0:${PORTSDIR}/net-mgmt/py-ipy
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
@@ -29,6 +29,8 @@ TESTS_BUILD_DEPENDS= ${RUN_DEPENDS} \
USES= python
USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
diff --git a/www/py-gandi.cli/distinfo b/www/py-gandi.cli/distinfo
index 19cba6a5c14c..76b581f4e256 100644
--- a/www/py-gandi.cli/distinfo
+++ b/www/py-gandi.cli/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gandi.cli-0.15.tar.gz) = 84c6e0aaa5fd509ab6b2e912a683f9090dc68ef122ae1a9df32ed0393df1ab7b
-SIZE (gandi.cli-0.15.tar.gz) = 359801
+SHA256 (gandi.cli-0.16.tar.gz) = e417f7f7f5f3a32ac777f7c1c74943d4604c7ed35dbb3f6c45fd2dafcdaa3acc
+SIZE (gandi.cli-0.16.tar.gz) = 379521
diff --git a/www/py-gandi.cli/files/patch-setup.py b/www/py-gandi.cli/files/patch-setup.py
index 861225e727dc..823f2109fd04 100644
--- a/www/py-gandi.cli/files/patch-setup.py
+++ b/www/py-gandi.cli/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2015-04-01 08:43:36 UTC
+--- setup.py.orig 2015-09-18 16:37:16 UTC
+++ setup.py
-@@ -6,19 +6,20 @@ import os
+@@ -6,11 +6,11 @@ import os
import sys
from setuptools import setup, find_packages
@@ -9,27 +9,26 @@
here = os.path.abspath(os.path.dirname(__file__))
-README = open(os.path.join(here, 'README.md')).read()
-CHANGES = open(os.path.join(here, 'CHANGES.rst')).read()
+-
+README = open(os.path.join(here, 'README.md'), encoding='utf-8').read()
+CHANGES = open(os.path.join(here, 'CHANGES.rst'), encoding='utf-8').read()
-
with open(os.path.join(here, 'gandi', 'cli', '__init__.py')) as v_file:
version = re.compile(r".*__version__ = '(.*?)'",
- re.S).match(v_file.read()).group(1)
+@@ -18,7 +18,7 @@ with open(os.path.join(here, 'gandi', 'c
--requires = ['setuptools', 'pyyaml', 'click<=4.0', 'requests', 'IPy']
-+requires = ['setuptools', 'pyyaml', 'click>=3.0', 'requests', 'IPy']
+ requires = ['setuptools', 'pyyaml', 'click>=3.1', 'requests', 'IPy']
-tests_require = ['nose', 'coverage', 'tox', 'httpretty==0.8.6']
-+tests_require = ['nose', 'httpretty==0.8.6' ]
++tests_require = ['nose', 'httpretty==0.8.6']
if sys.version_info < (2, 7):
tests_require += ['unittest2', 'importlib']
-@@ -52,6 +53,7 @@ setup(name='gandi.cli',
- zip_safe=False,
- install_requires=requires,
- tests_require=tests_require,
-+ test_suite='gandi.cli.tests',
- extras_require=extras_require,
- entry_points="""\
- [console_scripts]
+@@ -53,6 +53,7 @@ setup(name='gandi.cli',
+ zip_safe=False,
+ install_requires=requires,
+ tests_require=tests_require,
++ test_suite='gandi.cli.tests',
+ extras_require=extras_require,
+ entry_points={
+ 'console_scripts': [