aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-livereload/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-livereload/Makefile')
-rw-r--r--www/py-livereload/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/py-livereload/Makefile b/www/py-livereload/Makefile
new file mode 100644
index 000000000000..0e35a1ac0761
--- /dev/null
+++ b/www/py-livereload/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= livereload
+DISTVERSION= 2.5.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= WSGI for web developers to watch changes in realtime
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>0:www/py-tornado@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>