aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-plone.testing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.testing/Makefile')
-rw-r--r--www/py-plone.testing/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/py-plone.testing/Makefile b/www/py-plone.testing/Makefile
new file mode 100644
index 000000000000..967955aba1a8
--- /dev/null
+++ b/www/py-plone.testing/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-plone.testing
+# Date created: 02 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.testing
+PORTVERSION= 4.0.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Testing infrastructure for Zope and Plone projects
+
+LICENSE= BSD
+
+RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.event>=0:${PORTSDIR}/devel/py-zope.event \
+ ${PYTHON_PKGNAMEPREFIX}zope.configuration>=0:${PORTSDIR}/devel/py-zope.configuration \
+ ${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security \
+ ${PYTHON_PKGNAMEPREFIX}zope.app.publisher>=0:${PORTSDIR}/devel/py-zope.app.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.site>=0:${PORTSDIR}/devel/py-zope.site \
+ ${PYTHON_PKGNAMEPREFIX}zope.testbrowser>=0:${PORTSDIR}/devel/py-zope.testbrowser \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+#USE_ZOPE= yes
+
+.include <bsd.port.mk>