aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-recaptcha/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-recaptcha/Makefile')
-rw-r--r--www/py-recaptcha/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/py-recaptcha/Makefile b/www/py-recaptcha/Makefile
new file mode 100644
index 000000000000..d313a69db2a7
--- /dev/null
+++ b/www/py-recaptcha/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-recaptcha
+# Date created: 20 Mar 2009
+# Whom: Philip Paeps <philip@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= recaptcha
+PORTVERSION= 1.0.3
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/r/recaptcha-client
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-client-${PORTVERSION}
+
+MAINTAINER= philip@FreeBSD.org
+COMMENT= A plugin for reCAPTCHA and reCAPTCHA Mailhide
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= recaptcha_client
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>