aboutsummaryrefslogtreecommitdiffstats
path: root/www/qupzilla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/qupzilla/Makefile')
-rw-r--r--www/qupzilla/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/qupzilla/Makefile b/www/qupzilla/Makefile
index 96a757acb4a0..310e5444f389 100644
--- a/www/qupzilla/Makefile
+++ b/www/qupzilla/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= qupzilla
-PORTVERSION= 1.4.4
+PORTVERSION= 1.6.1
CATEGORIES= www
MASTER_SITES= http://www.qupzilla.com/uploads/
DISTNAME= QupZilla-${PORTVERSION}
@@ -11,9 +11,10 @@ COMMENT= Modern web browser based on WebKit core and Qt Framework
LICENSE= GPLv3
-LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
+LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-USES= desktop-file-utils qmake
+USES= desktop-file-utils pkgconfig qmake
USE_QT4= gui moc_build rcc_build uic_build webkit \
dbus xml script sql network imageformats_run linguist_build
QMAKE_ENV= QUPZILLA_PREFIX=${PREFIX}/
@@ -25,6 +26,8 @@ post-patch:
${WRKSRC}/tests/autotests/qztoolstest.cpp \
${WRKSRC}/src/lib/plugins/qtwebkit/spellcheck/speller.cpp
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
- ${WRKSRC}/src/install.pri
+ ${WRKSRC}/src/install.pri \
+ ${WRKSRC}/src/defines.pri \
+ ${WRKSRC}/src/lib/plugins/plugins.cpp
.include <bsd.port.mk>