aboutsummaryrefslogtreecommitdiffstats
path: root/www/rt40/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/rt40/Makefile')
-rw-r--r--www/rt40/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index b3461a570129..955d624c7994 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -15,7 +15,7 @@
PORTNAME= rt
PORTVERSION= 3.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/
@@ -30,9 +30,9 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-noportdocs-Makefile.in
CONFLICTS= rt-2* rt-3.0* rt-3.2* rt-3.4* rt-3.6*
LATEST_LINK= rt38
-OPTIONS= MYSQL "Enable MySQL backend" on \
- APACHE2 "Enable Apache2 server" on \
- MODPERL2 "Enable mod_perl2 support" on \
+OPTIONS= MYSQL "Enable MySQL backend" on \
+ APACHE2 "Enable Apache2 server" on \
+ MODPERL2 "Enable mod_perl2 support" on \
POSTGRESQL "Enable Postgresql backend" off \
ORACLE "Enable Oracle backend" off \
SQLITE "Enable SQLite backend" off \
@@ -194,6 +194,7 @@ pre-fetch:
post-patch:
@${RM} -f ${WRKSRC}/lib/RT.pm.in.orig
+ @${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!g' ${WRKSRC}/config.layout
@${REINPLACE_CMD} -e 's!%%SITE_PERL%%!${SITE_PERL}!g' ${WRKSRC}/config.layout
pre-install: