aboutsummaryrefslogtreecommitdiffstats
path: root/www/ruby-http-access/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/ruby-http-access/Makefile')
-rw-r--r--www/ruby-http-access/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/www/ruby-http-access/Makefile b/www/ruby-http-access/Makefile
new file mode 100644
index 000000000000..d57e1f16e13b
--- /dev/null
+++ b/www/ruby-http-access/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Ruby/http-access
+# Date created: 31 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http-access
+PORTVERSION= 0.0.4p3
+CATEGORIES= www ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/http-access/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS_EN= README_en.txt
+DOCS_JA= README_ja.txt
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/http-access.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>