aboutsummaryrefslogtreecommitdiffstats
path: root/www/rubygem-gollum-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/rubygem-gollum-lib/Makefile')
-rw-r--r--www/rubygem-gollum-lib/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/www/rubygem-gollum-lib/Makefile b/www/rubygem-gollum-lib/Makefile
index d18f458f9986..bde15a51684c 100644
--- a/www/rubygem-gollum-lib/Makefile
+++ b/www/rubygem-gollum-lib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gollum-lib
PORTVERSION= 4.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www rubygems
MASTER_SITES= RG
@@ -14,13 +14,26 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-gemojione>=2.2:graphics/rubygem-gemojione \
- rubygem-github-markup>=1.4:textproc/rubygem-github-markup \
rubygem-gollum-grit_adapter>=1.0:www/rubygem-gollum-grit_adapter \
rubygem-nokogiri>=1.6.4:textproc/rubygem-nokogiri \
rubygem-rouge>=2.0:textproc/rubygem-rouge \
rubygem-sanitize>=2.1:textproc/rubygem-sanitize \
rubygem-stringex>=2.6:devel/rubygem-stringex
+OPTIONS_RADIO= MARKUP
+OPTIONS_RADIO_MARKUP= GITHUB GITLAB
+OPTIONS_DEFAULT?= GITHUB
+
+MARKUP_DESC= Markup Selection
+GITHUB_DESC= Use rubygem-github-markup (default)
+GITLAB_DESC= Use rubygem-gitlab-markup instead
+
+GITHUB_RUN_DEPENDS= rubygem-github-markup>=1.4:textproc/rubygem-github-markup
+GITLAB_RUN_DEPENDS= rubygem-gitlab-markup>=1.5:textproc/rubygem-gitlab-markup
+
+GITHUB_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-github-gemspec
+GITLAB_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gitlab-gemspec
+
NO_ARCH= yes
USE_RUBY= yes
USES= gem