aboutsummaryrefslogtreecommitdiffstats
path: root/www/sams/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/sams/Makefile')
-rw-r--r--www/sams/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/www/sams/Makefile b/www/sams/Makefile
index 9559e3109f1c..cc986168aee5 100644
--- a/www/sams/Makefile
+++ b/www/sams/Makefile
@@ -22,16 +22,20 @@ USE_RC_SUBR= sams.sh
OPTIONS= NTLM "NTLM autorization/ActiveDirectory support" off \
APACHE22 "Use apache version 2.2" on \
- PHP5GD "Enable constructing graphs" on
+ INSTALLGD "Graphic reports" on
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_PHP= mysql
+USE_PHP= ctype curl gettext hash iconv json mysql \
+ pcre pdf pdo pdo_sqlite posix session \
+ session simplexml spl sqlite tokenizer \
+ xmlreader xmlwriter zlib
+
USE_MYSQL= 5.0
-CONFIGURE_ARGS= --with-configfile=${LOCALBASE}/etc/sams.conf \
- --with-rcd-locations=${LOCALBASE}/etc/rc.d/
+CONFIGURE_ARGS= --with-configfile=${PREFIX}/etc/sams.conf \
+ --with-rcd-locations=${PREFIX}/etc/rc.d/
SUB_FILES= pkg-message
@@ -39,11 +43,7 @@ SUB_FILES= pkg-message
.if defined(WITH_NTLM)
RUN_DEPENDS= ${LOCALBASE}/bin/ntlm_auth:${PORTSDIR}/net/samba3
-RUN_DEPENDS+= ${LOCALBASE}/include/php/ext/ldap/php_ldap.h:${PORTSDIR}/net/php5-ldap/
-.endif
-
-.if defined(WITH_PHP5GD)
-RUN_DEPENDS+= ${LOCALBASE}/include/php/ext/gd/php_gd.h:${PORTSDIR}/graphics/php5-gd/
+USE_PHP+= ldap
.endif
.if defined(WITH_APACHE22)
@@ -52,10 +52,18 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache22
RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
.endif
+.if defined(WITH_INSTALLGD)
+USE_PHP+= gd
+.endif
+
post-extract:
${INSTALL_SCRIPT} ${FILESDIR}/setup.sh ${WRKSRC}/
post-install:
+ @cp ${PREFIX}/share/sams/icon/classic/proxyes_32.jpg ${PREFIX}/share/sams/icon/bumper/proxyes_32.jpg
+ @cp ${PREFIX}/share/sams/icon/classic/cache_32.jpg ${PREFIX}/share/sams/icon/bumper/cache_32.jpg
+ @cp ${PREFIX}/share/sams/icon/classic/proxyes_48.jpg ${PREFIX}/share/sams/icon/bumper/proxyes_48.jpg
+ @cp ${PREFIX}/share/sams/icon/classic/cache_48.jpg ${PREFIX}/share/sams/icon/bumper/cache_48.jpg
@${CAT} ${PKGMESSAGE}
setup: