aboutsummaryrefslogtreecommitdiffstats
path: root/www/sarg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/sarg/Makefile')
-rw-r--r--www/sarg/Makefile36
1 files changed, 29 insertions, 7 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index f25079e5530f..7da2cfcb745b 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sarg
-PORTVERSION= 2.3.2
-PORTREVISION= 5
+PORTVERSION= 2.3.4
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,10 +12,9 @@ COMMENT= Squid log analyzer and HTML report generator
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS_DEFINE= GD PHP NLS
-OPTIONS_DEFAULT=GD PHP NLS
+OPTIONS_DEFINE= GD PHP NLS PCRE LDAP ICONV
+OPTIONS_DEFAULT=GD PHP NLS PCRE LDAP ICONV
-GD_DESC= Enable GD support
PHP_DESC= Install PHP for reporting generating
USE_AUTOTOOLS= autoconf aclocal
@@ -24,7 +22,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --sysconfdir="${ETCDIR}" \
+CONFIGURE_ARGS= CPPFLAGS=-I${LOCALBASE}/include \
+ --sysconfdir="${ETCDIR}" \
--enable-fontdir="${ETCDIR}/fonts" \
--enable-imagedir="${ETCDIR}/images"
@@ -35,14 +34,16 @@ MAN1= sarg.1
.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USE_GETTEXT= yes
-USE_ICONV= yes
.else
PLIST_SUB+= NLS="@comment "
CONFIGURE_ARGS+=--disable-nls
.endif
.if ${PORT_OPTIONS:MGD}
+CONFIGURE_ARGS+=--with-gd
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+.else
+CONFIGURE_ARGS+=--without-gd
.endif
.if ${PORT_OPTIONS:MPHP}
@@ -53,6 +54,27 @@ CONFIGURE_ARGS+=--disable-sargphp
PLIST_SUB+= PHP="@comment "
.endif
+.if ${PORT_OPTIONS:MPCRE}
+CONFIGURE_ARGS+=--with-pcre
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+.else
+CONFIGURE_ARGS+=--without-pcre
+.endif
+
+.if ${PORT_OPTIONS:MLDAP}
+CONFIGURE_ARGS+=--with-ldap
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+=--without-ldap
+.endif
+
+.if ${PORT_OPTIONS:MICONV}
+CONFIGURE_ARGS+=--with-iconv
+USE_ICONV= yes
+.else
+CONFIGURE_ARGS+=--without-iconv
+.endif
+
post-extract:
@${FIND} ${WRKSRC} -type d -exec ${CHMOD} 0755 {} \;
@${CHMOD} 0755 ${WRKSRC}/configure