aboutsummaryrefslogtreecommitdiffstats
path: root/www/screem-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/screem-devel/Makefile')
-rw-r--r--www/screem-devel/Makefile45
1 files changed, 13 insertions, 32 deletions
diff --git a/www/screem-devel/Makefile b/www/screem-devel/Makefile
index 4b0842f8d26c..4ffc0d8384a9 100644
--- a/www/screem-devel/Makefile
+++ b/www/screem-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= screem
-PORTVERSION= 0.12.1
-PORTREVISION= 3
+PORTVERSION= 0.14.1
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,42 +14,24 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Nice GNOME/GTK-based HTML editor
-LIB_DEPENDS+= neon.24:${PORTSDIR}/www/neon \
- croco-${CROCO_VERSION}.3:${PORTSDIR}/textproc/libcroco \
- dbus-1.1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
+ croco-0.6.3:${PORTSDIR}/textproc/libcroco
-USE_GMAKE= yes
-USE_REINPLACE= yes
USE_X_PREFIX= yes
+USE_GNOME= desktopfileutils gnomehack gnomeprefix gnometarget \
+ gtksourceview intlhack libgnomeprintui libgnomeui libgtkhtml
USE_XPM= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui libgtkhtml \
- gtksourceview intlhack desktopfileutils
-USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_OMF= yes
GCONF_SCHEMAS= screem.schemas
-CROCO_VERSION= 0.6
-
-.if !defined(WITHOUT_OPENSSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --with-ssl
-.endif
-
-USE_PERL5= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --without-included-neon
-
post-patch:
- @${REINPLACE_CMD} -e 's|\$${DATADIRNAME}/\$${PACKAGE}/pixmaps|\$${DATADIRNAME}/gnome/\$${PACKAGE}/pixmaps|g' \
- ${WRKSRC}/configure
-
-post-configure:
- @${REINPLACE_CMD} -e 's|\/\* #undef HAVE_LIMITS_H \*\/|#define HAVE_LIMITS_H 1|g' ${WRKSRC}/config.h
-
-# HACK: This allows test builds into a temporary directory, but in the REAL world,
-# gconf would have created this directory.
-pre-install:
- @${MKDIR} ${PREFIX}/etc/gconf/gconf.xml.defaults
+ @${REINPLACE_CMD} -e 's|$${DATADIRNAME}/$${PACKAGE}|$${DATADIRNAME}/gnome/$${PACKAGE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\&\& make|\&\& $$(MAKE)|g' ${WRKSRC}/tests/Makefile.in
.include <bsd.port.mk>