aboutsummaryrefslogtreecommitdiffstats
path: root/www/surf
diff options
context:
space:
mode:
Diffstat (limited to 'www/surf')
-rw-r--r--www/surf/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/surf/Makefile b/www/surf/Makefile
index e7178bd5a478..2bb1476c1718 100644
--- a/www/surf/Makefile
+++ b/www/surf/Makefile
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
-USE_CSTD= c99
USE_GNOME= gtk20
+USE_XORG= x11
USES= pkgconfig
PORTDOCS= README
@@ -28,9 +28,6 @@ DESKTOP_ENTRIES="Surf" "" "${PREFIX}/share/pixmaps/surf.png" "surf" "" true
CONFLICTS= surf-1* # math/surf
-# Name conflicts with the math/surf port
-NO_LATEST_LINK= yes
-
.include <bsd.port.options.mk>
pre-everything::
@@ -45,11 +42,14 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
- 's|^\(PREFIX\)|#\1| ; \
+ '/^PREFIX/d ; \
s|/share/man|/man| ; \
- s|^\(CFLAGS\) =.*|\1 += -I. $${GTKINC} $${CPPFLAGS}| ; \
- s|^\(LDFLAGS\) =.*|\1 += $${GTKLIB}| ; \
- s|^\(CC\)|#\1|' ${WRKSRC}/config.mk
+ /^X11INC =/s/=.*/= `pkg-config --cflags x11`/ ; \
+ /^X11LIB =/s/=.*/= `pkg-config --libs x11`/ ; \
+ /^CPPFLAGS =/s|$$| ${CPPFLAGS}| ; \
+ /^CFLAGS =/s|-Os| ${CFLAGS}| ; \
+ /^LDFLAGS =/s|$$| ${LDFLAGS}| ; \
+ /^CC =/d' ${WRKSRC}/config.mk
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/surf