aboutsummaryrefslogtreecommitdiffstats
path: root/www/trac-simpleticket/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/trac-simpleticket/Makefile')
-rw-r--r--www/trac-simpleticket/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/trac-simpleticket/Makefile b/www/trac-simpleticket/Makefile
new file mode 100644
index 000000000000..e5b0cfe21edd
--- /dev/null
+++ b/www/trac-simpleticket/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trac-simpleticket
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simpleticket
+PORTVERSION= 1.1.3
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Simplified Ticket Entry
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>