aboutsummaryrefslogtreecommitdiffstats
path: root/www/trac-wikinotification/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/trac-wikinotification/Makefile')
-rw-r--r--www/trac-wikinotification/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/trac-wikinotification/Makefile b/www/trac-wikinotification/Makefile
new file mode 100644
index 000000000000..c97d0e365ca8
--- /dev/null
+++ b/www/trac-wikinotification/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: trac-wikinotification
+# Date created: December 28 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wikinotification
+PORTVERSION= 0.1.0p4
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/downloads/trac-hacks/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/rc/}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Allow email notifications on wiki page changes
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ ${PYTHON_SITELIBDIR}/TracCtxtnavAdd-1.1_r1-py${_PYTHON_VERSION}.egg:${PORTSDIR}/www/trac-ctxtnavadd
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_ZIP= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB+= PORTVERSION=${PORTVERSION:S/p/rc/} PYTHONVERSION=${_PYTHON_VERSION}
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>