aboutsummaryrefslogtreecommitdiffstats
path: root/www/uwsgi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/uwsgi/Makefile')
-rw-r--r--www/uwsgi/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
new file mode 100644
index 000000000000..59fef9bb4e42
--- /dev/null
+++ b/www/uwsgi/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: uwsgi
+# Date created: 23 May 2010
+# Whom: Daniel Gerzo <danger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uwsgi
+PORTVERSION= 0.9.5.1
+CATEGORIES= www python
+MASTER_SITES= http://projects.unbit.it/downloads/
+
+MAINTAINER= danger@FreeBSD.org
+COMMENT= Developer-friendly WSGI server which uses uwsgi protocol
+
+MAKE_JOBS_SAFE= yes
+
+USE_GNOME= libxml2
+USE_PYTHON= 2.4+
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>