aboutsummaryrefslogtreecommitdiffstats
path: root/www/varnish-nagios/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/varnish-nagios/Makefile')
-rw-r--r--www/varnish-nagios/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/varnish-nagios/Makefile b/www/varnish-nagios/Makefile
new file mode 100644
index 000000000000..1cded6e8d32d
--- /dev/null
+++ b/www/varnish-nagios/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: varnish-nagios
+# Date created: 2012-04-15
+# Whom: anders
+#
+# $FreeBSD$
+#
+
+PORTNAME= varnish-nagios
+DISTVERSION= 1.1
+CATEGORIES= www
+MASTER_SITES= http://repo.varnish-cache.org/source/ \
+ http://anders.fupp.net/distfiles/
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Varnish Nagios
+
+BUILD_DEPENDS= ${LOCALBASE}/include/varnish/varnishapi.h:${PORTSDIR}/www/varnish
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+
+USE_GNOME= pkgconfig
+
+PLIST_FILES= libexec/nagios/check_varnish
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_varnish ${PREFIX}/libexec/nagios
+
+.include <bsd.port.mk>