aboutsummaryrefslogtreecommitdiffstats
path: root/www/varnish2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/varnish2/Makefile')
-rw-r--r--www/varnish2/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 6fe3b1320c30..50a684c0ebfc 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= varnish
-PORTVERSION= 1.0.4
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,11 +16,13 @@ COMMENT= The Varnish high-performance HTTP accelerator
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --localstatedir=${PREFIX}
USE_LDCONFIG= yes
-MAN1= varnishd.1 varnishhist.1 varnishlog.1 varnishncsa.1 \
- varnishstat.1 varnishtop.1
+MAN1= varnishadm.1 varnishd.1 varnishhist.1 varnishlog.1 \
+ varnishncsa.1 varnishreplay.1 varnishstat.1 varnishtop.1
MAN7= vcl.7
+USE_REINPLACE= YES
USE_RC_SUBR= varnishd varnishlog
.include <bsd.port.pre.mk>
@@ -30,6 +31,10 @@ USE_RC_SUBR= varnishd varnishlog
BROKEN= does not compile
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
post-install:
${MKDIR} ${PREFIX}/etc/varnish
@[ -f ${PREFIX}/etc/varnish/default.vcl ] || \