aboutsummaryrefslogtreecommitdiffstats
path: root/www/woof/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/woof/Makefile')
-rw-r--r--www/woof/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/www/woof/Makefile b/www/woof/Makefile
index fa6de63f63d6..b85049a12b12 100644
--- a/www/woof/Makefile
+++ b/www/woof/Makefile
@@ -22,7 +22,17 @@ USE_PYTHON= yes
NO_BUILD= yes
PLIST_FILES= bin/woof
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 270
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-woof-2009-12-27-python27.diff
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${DISTFILES}
+
do-install:
- ${INSTALL_SCRIPT} ${DISTDIR}/${DISTFILES} ${PREFIX}/bin/woof
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTFILES} ${PREFIX}/bin/woof
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>