aboutsummaryrefslogtreecommitdiffstats
path: root/www/xist/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/xist/Makefile')
-rw-r--r--www/xist/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/xist/Makefile b/www/xist/Makefile
index 30bee9bd55db..b3ace371b7ad 100644
--- a/www/xist/Makefile
+++ b/www/xist/Makefile
@@ -15,10 +15,16 @@ COMMENT= XML-based extensible HTML generator
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.4:${PORTSDIR}/devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}pillow>2.6:${PORTSDIR}/graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.6:${PORTSDIR}/graphics/py-pillow \
${PYTHON_PKGNAMEPREFIX}cssutils>=1.0:${PORTSDIR}/www/py-cssutils
USES= python:3 tar:bzip2
USE_PYTHON= autoplist distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>