aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-tags/Makefile28
-rw-r--r--www/trac-tags/distinfo3
-rw-r--r--www/trac-tags/pkg-descr6
-rw-r--r--www/trac-tags/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7263dab062be..528bf406b6cc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1054,6 +1054,7 @@
SUBDIR += trac-addcomment
SUBDIR += trac-ctxtnavadd
SUBDIR += trac-gantt
+ SUBDIR += trac-tags
SUBDIR += trac-webadmin
SUBDIR += transproxy
SUBDIR += twhttpd
diff --git a/www/trac-tags/Makefile b/www/trac-tags/Makefile
new file mode 100644
index 000000000000..068e742c2899
--- /dev/null
+++ b/www/trac-tags/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: trac-tags
+# Date created: December 28 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tags
+PORTVERSION= 0.4
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/downloads/trac-hacks/
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= A generic tags frontend for trac
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_ZIP= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-tags/distinfo b/www/trac-tags/distinfo
new file mode 100644
index 000000000000..f349b8f6404d
--- /dev/null
+++ b/www/trac-tags/distinfo
@@ -0,0 +1,3 @@
+MD5 (tags-0.4.zip) = 7da9f166b40dfcfbfdc9d9923af7fabf
+SHA256 (tags-0.4.zip) = f1151716afa2a5b209efa3ba1a704995848f70e94f5d51a9260b470cacecf71d
+SIZE (tags-0.4.zip) = 57854
diff --git a/www/trac-tags/pkg-descr b/www/trac-tags/pkg-descr
new file mode 100644
index 000000000000..42811568371a
--- /dev/null
+++ b/www/trac-tags/pkg-descr
@@ -0,0 +1,6 @@
+The TagsPlugin implements both a generic tagging engine and frontends for the
+Wiki and ticket systems. An extra text entry box is added to the Wiki edit page
+for tagging Wiki pages and ticket fields (you can configure which ones) are
+treated as tags for the ticket system.
+
+WWW: http://trac-hacks.org/wiki/TagsPlugin
diff --git a/www/trac-tags/pkg-plist b/www/trac-tags/pkg-plist
new file mode 100644
index 000000000000..3028877f6e4f
--- /dev/null
+++ b/www/trac-tags/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracTags-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg