aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/drupal5/bsd.drupal.mk21
1 files changed, 5 insertions, 16 deletions
diff --git a/www/drupal5/bsd.drupal.mk b/www/drupal5/bsd.drupal.mk
index dfab8a915e6d..ae098e30dfb4 100644
--- a/www/drupal5/bsd.drupal.mk
+++ b/www/drupal5/bsd.drupal.mk
@@ -1,13 +1,13 @@
# $FreeBSD$
#
-# Make sure we cannot define any combination of DRUPAL{4,5,6}
-.if (defined(DRUPAL4_MODULE) && defined(DRUPAL5_MODULE)) || (defined(DRUPAL4_MODULE) && defined(DRUPAL6_MODULE)) || (defined(DRUPAL5_MODULE) && defined(DRUPAL6_MODULE))
-BROKEN= cannot define a combination of DRUPAL4_MODULE, DRUPAL5_MODULE and DRUPAL6_MODULE
+# Make sure we cannot define any combination of DRUPAL{5,6}
+.if (defined(DRUPAL5_MODULE) && defined(DRUPAL6_MODULE))
+BROKEN= cannot define a combination of DRUPAL5_MODULE and DRUPAL6_MODULE
.endif
# Make sure DRUPAL_MODULE is defined. If no DRUPAL*_module defined, then define DRUPAL4_MODULE
-.if defined(DRUPAL4_MODULE) || defined(DRUPAL5_MODULE) || defined(DRUPAL6_MODULE)
+.if defined(DRUPAL5_MODULE) || defined(DRUPAL6_MODULE)
DRUPAL_MODULE?= yes
.endif
@@ -16,7 +16,7 @@ DRUPAL_MODTYPE= modules
.endif
# Make sure DRUPAL_PORT is defined. If no DRUPAL*_module defined, then define DRUPAL4_PORT
-.if defined(DRUPAL4_PORT) || defined(DRUPAL5_PORT) || defined(DRUPAL6_PORT)
+.if defined(DRUPAL5_PORT) || defined(DRUPAL6_PORT)
DRUPAL_PORT?= yes
.endif
@@ -31,8 +31,6 @@ DRUPAL_BASE?= www/drupal6
.else
.if defined(DRUPAL5_MODULE) || defined(DRUPAL5_PORT) || defined(DRUPAL5_THEME)
DRUPAL_BASE?= www/drupal5
-.else
-DRUPAL_BASE?= www/drupal4
.endif
.endif
@@ -47,15 +45,6 @@ DOCSDIR?= ${DRUPAL_DOCSDIR}
.if defined(DRUPAL_MODULE) || defined (DRUPAL_THEME)
-.if defined(DRUPAL4_MODULE)
-PKGNAMEPREFIX= drupal4-
-DRUPAL_VERSION?= 4.7.0
-.if defined(DRUPAL_MODSUBDIR)
-DRUPAL_MODDIR?= ${DRUPAL_BASE}/${DRUPAL_MODTYPE}/${DRUPAL_MODSUBDIR}
-.else
-DRUPAL_MODDIR?= ${DRUPAL_BASE}/${DRUPAL_MODTYPE}
-.endif
-.endif
.if defined(DRUPAL5_MODULE) || defined (DRUPAL5_THEME)
PKGNAMEPREFIX= drupal5-
streamer0.10-removal&id=d85b2722d2e9107530480abbe0d7e9581cd4e342'>- fix plistdinoex2008-01-181-1/+0 * - update to 4.4.4dinoex2008-01-133-120/+13 * - take maintanershipdinoex2007-12-121-1/+1 * Reassign to ports@ by maintainer request.linimon2007-10-281-1/+1 * comms/hylafax: update to 4.3.3edwin2007-09-094-23/+39 * - Hylafax has been released in version 4.3.2clsung2007-02-223-179/+392 * - Update to 4.3.0pav2006-10-075-18/+9 * Pass maintainer-ship to submitter.ehaupt2006-05-311-1/+1 * - Clean up distinfo for unmaintained ports: remove CVS tags, empty lines etc.sem2006-05-071-0/+1 * remove USE_REINPLACE for all ports with categories starting with Cedwin2006-05-041-1/+0 * - Add gawk on BUILD_DEPENDS toogarga2006-03-021-1/+2 * Update to 4.2.5.lawrance2006-02-1111-643/+38 * Reset inactive maintainer (several timeouts).linimon2006-02-101-1/+1 * BROKEN: Configure failskris2006-01-201-0/+2 * - Use gawk instead of awk. This fixes a problem sending email notifications.lawrance2005-11-102-2/+6 * Backport a patch from Hylafax CVS which fixes a problem sending faxes on 5.x.lawrance2005-10-082-1/+62