aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-textile/Makefile23
-rw-r--r--www/py-textile/distinfo3
-rw-r--r--www/py-textile/pkg-descr4
-rw-r--r--www/py-textile/pkg-plist1
5 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 55cc090f1b0f..8cc76777a572 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1186,6 +1186,7 @@
SUBDIR += py-scgi
SUBDIR += py-scriptaculous
SUBDIR += py-slimmer
+ SUBDIR += py-textile
SUBDIR += py-tgwebservices
SUBDIR += py-turbodjango
SUBDIR += py-turbogears
diff --git a/www/py-textile/Makefile b/www/py-textile/Makefile
new file mode 100644
index 000000000000..67ac54f05b82
--- /dev/null
+++ b/www/py-textile/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-textile
+# Date created: 2008-09-05
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= textile
+PORTVERSION= 2.0.11
+CATEGORIES= www textproc
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= Textile markup generator written in Python
+
+PROJECTHOST= pytextile
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_NOEGGINFO= yes
+PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>
diff --git a/www/py-textile/distinfo b/www/py-textile/distinfo
new file mode 100644
index 000000000000..bce90adb12ed
--- /dev/null
+++ b/www/py-textile/distinfo
@@ -0,0 +1,3 @@
+MD5 (textile-2.0.11.tar.gz) = a94aee1f9610aae6605c6e72b6a1f660
+SHA256 (textile-2.0.11.tar.gz) = 8d1f277c541d2638f8be3fa5ebb01762e01ce9d1792ae7bcdca443716964bf59
+SIZE (textile-2.0.11.tar.gz) = 28727
diff --git a/www/py-textile/pkg-descr b/www/py-textile/pkg-descr
new file mode 100644
index 000000000000..64d93c1dcccf
--- /dev/null
+++ b/www/py-textile/pkg-descr
@@ -0,0 +1,4 @@
+Textile is a Python implementation of the Textile
+(http://textism.com/tools/textile) markup language.
+
+WWW: http://code.google.com/p/pytextile/
diff --git a/www/py-textile/pkg-plist b/www/py-textile/pkg-plist
new file mode 100644
index 000000000000..47682a96305b
--- /dev/null
+++ b/www/py-textile/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/textile-%%VERSION%%-py%%PYVER%%.egg