aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mod_musicindex/Makefile37
-rw-r--r--www/mod_musicindex/distinfo5
-rw-r--r--www/mod_musicindex/pkg-plist13
3 files changed, 38 insertions, 17 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 1211b8ee3fe6..d9555e900462 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,22 +6,24 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 1.3.3
-PORTREVISION= 4
+PORTVERSION= 1.3.5
CATEGORIES= www audio
-MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/oldsrc/
+MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that allows downloading and streaming of audio
+LICENSE= LGPL21
+
OPTIONS= NLS "Native language support" on \
FLAC "FLAC support" off \
MP3 "MP3 support" on \
MP4 "MP4 support" off \
VORBIS "Ogg/Vorbis support" off \
LIBARCHIVE "Archive downloading support" on \
- FILECACHE "Caching support" on
+ FILECACHE "Flat file caching support" on \
+ MYSQLCACHE "MySQL caching support" off
MAKE_JOBS_SAFE= yes
@@ -29,7 +31,8 @@ USE_APACHE= 2.0+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --with-apxs=${APXS}
+CONFIGURE_ARGS= --with-apxs=${APXS} \
+ --disable-libFLACtest --disable-vorbistest
SUB_FILES= pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
@@ -39,7 +42,7 @@ PORTDOCS= README
.include <bsd.port.options.mk>
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
@@ -54,7 +57,7 @@ LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
.endif
.if defined(WITHOUT_MP3)
-CONFIGURE_ARGS+=--disable-mp3
+CONFIGURE_ARGS+= --disable-mp3
.else
LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
mad:${PORTSDIR}/audio/libmad
@@ -80,6 +83,26 @@ CONFIGURE_ARGS+= --disable-archive
CONFIGURE_ARGS+= --disable-filecache
.endif
+.if defined(WITHOUT_MYSQLCACHE)
+CONFIGURE_ARGS+= --disable-mysqlcache
+.else
+USE_MYSQL= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/@BUILD_FOR_APACHE2/ s| -i -n musicindex| -a &|' \
+ ${WRKSRC}/src/Makefile.in
+.if !defined(WITHOUT_NLS)
+ ${RM} ${WRKSRC}/po/*.gmo
+ ${MV} ${WRKSRC}/po/pt-br.po ${WRKSRC}/po/pt_BR.po
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|pt-br|pt_BR|g' ${WRKSRC}/po/LINGUAS ${WRKSRC}/po/pt_BR.po
+.endif
+
+post-build:
+.if !defined(WITHOUT_NLS)
+ cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${MAKE} update-gmo
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/
diff --git a/www/mod_musicindex/distinfo b/www/mod_musicindex/distinfo
index 981432f7a4b6..059f4e75ba08 100644
--- a/www/mod_musicindex/distinfo
+++ b/www/mod_musicindex/distinfo
@@ -1,3 +1,2 @@
-MD5 (mod_musicindex-1.3.3.tar.gz) = 6488db2d6e9dd814fb9d47c7b390c777
-SHA256 (mod_musicindex-1.3.3.tar.gz) = ae8cb26c946fe2175d09ed89099ddf6f10547ae81e4842cea4627d24d93d1b82
-SIZE (mod_musicindex-1.3.3.tar.gz) = 482313
+SHA256 (mod_musicindex-1.3.5.tar.gz) = e9178f8dd6481f2614a17ba1cdf55ec55636cd0802866d236b4230ee801d67ca
+SIZE (mod_musicindex-1.3.5.tar.gz) = 488090
diff --git a/www/mod_musicindex/pkg-plist b/www/mod_musicindex/pkg-plist
index 26d0a588f01a..473af3337d19 100644
--- a/www/mod_musicindex/pkg-plist
+++ b/www/mod_musicindex/pkg-plist
@@ -1,20 +1,19 @@
%%APACHEMODDIR%%/%%AP_MODULE%%
@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
-%%DATADIR%%/musicindex.css
%%DATADIR%%/directory.png
%%DATADIR%%/fetch.png
+%%DATADIR%%/fetchok.png
%%DATADIR%%/general.png
+%%DATADIR%%/musicindex.css
%%DATADIR%%/right_arrow.gif
-%%DATADIR%%/sound.png
-%%DATADIR%%/shuffle.png
%%DATADIR%%/rss.png
-%%DATADIR%%/fetchok.png
+%%DATADIR%%/shuffle.png
+%%DATADIR%%/sound.png
%%DATADIR%%/soundok.png
+%%NLS%%share/locale/de/LC_MESSAGES/mod_musicindex.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mod_musicindex.mo
%%NLS%%share/locale/it/LC_MESSAGES/mod_musicindex.mo
%%NLS%%share/locale/nl/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%share/locale/pt-br/LC_MESSAGES/mod_musicindex.mo
-%%NLS%%@dirrm share/locale/pt-br/LC_MESSAGES
-%%NLS%%@dirrm share/locale/pt-br
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/mod_musicindex.mo
@dirrm %%DATADIR%%