aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Compress-Gzip/Makefile27
-rw-r--r--www/p5-CGI-Compress-Gzip/distinfo3
-rw-r--r--www/p5-CGI-Compress-Gzip/pkg-descr6
-rw-r--r--www/p5-CGI-Compress-Gzip/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index df5755d986c6..8a99fb5a1fb6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -642,6 +642,7 @@
SUBDIR += p5-CGI-Builder
SUBDIR += p5-CGI-Builder-TT2
SUBDIR += p5-CGI-Cache
+ SUBDIR += p5-CGI-Compress-Gzip
SUBDIR += p5-CGI-Cookie-Splitter
SUBDIR += p5-CGI-Deurl-XS
SUBDIR += p5-CGI-Ex
diff --git a/www/p5-CGI-Compress-Gzip/Makefile b/www/p5-CGI-Compress-Gzip/Makefile
new file mode 100644
index 000000000000..fa7cfcf6613f
--- /dev/null
+++ b/www/p5-CGI-Compress-Gzip/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-CGI-Compress-Gzip
+# Date created: 11 September 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Compress-Gzip
+PORTVERSION= 0.22
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= CGI::Compress::Gzip - CGI with automatically compressed output
+
+BUILD_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Compress::Gzip.3 \
+ CGI::Compress::Gzip::FileHandle.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Compress-Gzip/distinfo b/www/p5-CGI-Compress-Gzip/distinfo
new file mode 100644
index 000000000000..dcb3a0716bb1
--- /dev/null
+++ b/www/p5-CGI-Compress-Gzip/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Compress-Gzip-0.22.tgz) = f82809411065c9636b81f8e021c99723
+SHA256 (CGI-Compress-Gzip-0.22.tgz) = 9c540866a80f615af6bf07a7a940209d2085020d9ef4a0c609bf7d106648606e
+SIZE (CGI-Compress-Gzip-0.22.tgz) = 23481
diff --git a/www/p5-CGI-Compress-Gzip/pkg-descr b/www/p5-CGI-Compress-Gzip/pkg-descr
new file mode 100644
index 000000000000..5d6a0be1bba3
--- /dev/null
+++ b/www/p5-CGI-Compress-Gzip/pkg-descr
@@ -0,0 +1,6 @@
+CGI::Compress::Gzip extends the CGI class to auto-detect whether the
+client browser wants compressed output and apply gzip compression on any
+content printed on the default filehandle. This module is intended to
+be a drop-in replacement for CGI.pm in a typical scripting environment.
+
+WWW: http://search.cpan.org/dist/CGI-Compress-Gzip/
diff --git a/www/p5-CGI-Compress-Gzip/pkg-plist b/www/p5-CGI-Compress-Gzip/pkg-plist
new file mode 100644
index 000000000000..7aad89dcc8c5
--- /dev/null
+++ b/www/p5-CGI-Compress-Gzip/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/CGI/Compress/Gzip.pm
+%%SITE_PERL%%/CGI/Compress/Gzip/FileHandle.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Compress/Gzip
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Compress
+@dirrmtry %%SITE_PERL%%/CGI/Compress/Gzip
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI
+@dirrmtry %%SITE_PERL%%/CGI/Compress
+@dirrmtry %%SITE_PERL%%/CGI