aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/falkon/Makefile4
-rw-r--r--www/otter-browser/Makefile7
-rw-r--r--www/py-qt5-webchannel/Makefile2
-rw-r--r--www/py-qt5-webengine/Makefile4
-rw-r--r--www/qt5-webchannel/Makefile3
-rw-r--r--www/qt5-webengine/Makefile4
-rw-r--r--www/qt5-webkit/Makefile4
-rw-r--r--www/qt5-websockets-qml/Makefile3
8 files changed, 17 insertions, 14 deletions
diff --git a/www/falkon/Makefile b/www/falkon/Makefile
index 1e4fd1e07dae..b26c498048d0 100644
--- a/www/falkon/Makefile
+++ b/www/falkon/Makefile
@@ -2,7 +2,7 @@
PORTNAME= falkon
DISTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= KDE/stable/falkon/${DISTVERSION:R}/src/
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake:outsource desktop-file-utils kde:5 qt:5 ssl tar:xz
USE_KDE= wallet
-USE_QT= core dbus gui location network printsupport qml quick \
+USE_QT= core dbus declarative gui location network printsupport \
sql webchannel webengine widgets x11extras \
buildtools_build qmake_build
USE_XORG= xcb
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index d99540d690e5..484f2e702764 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -3,6 +3,7 @@
PORTNAME= otter-browser
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.99.3
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= kde@FreeBSD.org
@@ -14,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell
USES= cmake:outsource compiler:c++11-lib desktop-file-utils qt:5
-USE_QT= concurrent core dbus gui multimedia network printsupport \
- qml script sql sql-sqlite3 svg widgets xmlpatterns \
+USE_QT= concurrent core dbus declarative gui multimedia network printsupport \
+ script sql sql-sqlite3 svg widgets xmlpatterns \
buildtools_build qmake_build
USE_GITHUB= yes
@@ -28,7 +29,7 @@ OPTIONS_DEFAULT= QTWEBENGINE QTWEBKIT
QTWEBENGINE_DESC= Build QtWebEngine backend
QTWEBKIT_DESC= Build QtWebKit backend
-QTWEBENGINE_USE= qt=location,quick,webchannel,webengine
+QTWEBENGINE_USE= qt=declarative,location,webchannel,webengine
QTWEBENGINE_CMAKE_BOOL= ENABLE_QTWEBENGINE
QTWEBKIT_USE= qt=webkit
diff --git a/www/py-qt5-webchannel/Makefile b/www/py-qt5-webchannel/Makefile
index f8696ae25dec..5b765babbd99 100644
--- a/www/py-qt5-webchannel/Makefile
+++ b/www/py-qt5-webchannel/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python bindings for the Qt5 toolkit, QtWebChannel module
USES= python pyqt:5 qt:5
USE_PYQT= sip_build core_run gui_run network_run qml_run widgets_run
USE_PYTHON= flavors
-USE_QT= core qmake_build gui network qml webchannel widgets
+USE_QT= core declarative qmake_build gui network webchannel widgets
CONFIGURE_ARGS= --enable QtWebChannel \
--no-stubs
diff --git a/www/py-qt5-webengine/Makefile b/www/py-qt5-webengine/Makefile
index 2de59ae595e7..1ff7cef5890c 100644
--- a/www/py-qt5-webengine/Makefile
+++ b/www/py-qt5-webengine/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= webengine
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www devel python
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run network_run webchannel_run
USE_PYTHON= flavors
-USE_QT= core gui location network printsupport qml quick webchannel \
+USE_QT= core declarative gui location network printsupport webchannel \
webengine widgets qmake_build
CONFIGURE_ARGS= --enable QtWebEngine \
diff --git a/www/qt5-webchannel/Makefile b/www/qt5-webchannel/Makefile
index 23120d2ea46a..e7813ca1d593 100644
--- a/www/qt5-webchannel/Makefile
+++ b/www/qt5-webchannel/Makefile
@@ -2,13 +2,14 @@
PORTNAME= webchannel
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 library for integration of C++/QML with HTML/js clients
-USE_QT= buildtools_build core qml quick
+USE_QT= buildtools_build core declarative
USES= compiler:c++11-lang qmake:norecursive qt-dist:5,webchannel
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 3817aff190bc..cdd10a2b4527 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -20,7 +20,7 @@
PORTNAME= webengine
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= www
PKGNAMEPREFIX= qt5-
@@ -73,7 +73,7 @@ SNDIO_VARS_OFF= QMAKE_CONFIGURE_ARGS+=-no-sndio
USES= gperf jpeg python:2.7,build pkgconfig \
qmake:norecursive,outsource qt-dist:5,webengine shebangfix
USE_GNOME= glib20 libxml2 libxslt
-USE_QT= core designer gui location network qml quick webchannel \
+USE_QT= core declarative designer gui location network webchannel \
widgets buildtools_build qmake_build printsupport
USE_XORG= x11 xcb xcomposite xcursor xext xi xorgproto \
xrandr xrender xscrnsaver xtst
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index f476206f4b69..fcf0360ddbe9 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -24,8 +24,8 @@ USES= bison cmake:outsource compiler:c++11-lang gperf jpeg \
tar:xz
USE_GNOME= glib20 libxml2 libxslt
USE_GSTREAMER1= core
-USE_QT= core gui location network opengl printsupport \
- qml quick sensors testlib webchannel widgets \
+USE_QT= core declarative gui location network opengl printsupport \
+ sensors testlib webchannel widgets \
buildtools_build qmake_build
USE_RUBY= yes
USE_XORG= x11 xcomposite xrender
diff --git a/www/qt5-websockets-qml/Makefile b/www/qt5-websockets-qml/Makefile
index 38e23297e4dc..da8423c96151 100644
--- a/www/qt5-websockets-qml/Makefile
+++ b/www/qt5-websockets-qml/Makefile
@@ -2,13 +2,14 @@
PORTNAME= websockets-qml
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= www
PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt implementation of WebSocket protocol (QML bindings)
-USE_QT= buildtools_build core network qml quick websockets
+USE_QT= buildtools_build core declarative network websockets
USES= qmake qt-dist:5,websockets
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}