aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/netsurf/Makefile67
-rw-r--r--www/netsurf/distinfo4
-rw-r--r--www/netsurf/files/Makefile.config6
-rw-r--r--www/netsurf/files/patch-gtk_Makefile.target15
-rw-r--r--www/netsurf/files/patch-pixel-format89
-rw-r--r--www/netsurf/files/patch-src__nsgenbind-0.0.1__src__nsgenbind-lexer.l19
-rw-r--r--www/netsurf/files/patch-src__nsgenbind-0.0.1__src__webidl-lexer.l18
-rw-r--r--www/netsurf/pkg-plist198
8 files changed, 148 insertions, 268 deletions
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index 83d5c6b3f83a..3b52147fe162 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -2,75 +2,68 @@
# $FreeBSD$
PORTNAME= netsurf
-PORTVERSION= 3.0
-PORTREVISION= 6
+PORTVERSION= 3.4
CATEGORIES= www
-MASTER_SITES= http://download.netsurf-browser.org/netsurf/releases/source-full/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-full-src
+MASTER_SITES= http://download.netsurf-browser.org/netsurf/releases/source/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= olivierd@FreeBSD.org
COMMENT= Lightweight web browser
LICENSE= GPLv2 MIT
LICENSE_COMB= multi
-BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+BUILD_DEPENDS= duk:${PORTSDIR}/lang/duktape \
+ nsgenbind:${PORTSDIR}/devel/nsgenbind \
+ p5-HTML-Parser>=3.72:${PORTSDIR}/www/p5-HTML-Parser
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libpng.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png \
+ libnsutils.so:${PORTSDIR}/devel/libnsutils \
+ libutf8proc.so:${PORTSDIR}/textproc/libutf8proc \
+ libnsgif.so:${PORTSDIR}/graphics/libnsgif \
+ libnsbmp.so:${PORTSDIR}/graphics/libnsbmp \
+ libdom.so:${PORTSDIR}/www/libdom \
+ libcss.so:${PORTSDIR}/textproc/libcss
ALL_TARGET= #empty
-CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lssl -lcrypto -L${LOCALBASE}/lib ${ICONV_LIB}
MAKE_ARGS= HOST_CC="${CC}" CC="${CC}" CCOPT="" HOST="${OPSYS}" \
WARNFLAGS="" Q="" OPTCFLAGS="${CFLAGS}"
-USES= bison gmake gperf iconv jpeg pkgconfig
-USE_GNOME= gtk20 librsvg2
+MAKE_ENV+= COMPONENT_TYPE="lib-shared" \
+ FLEX="${LOCALBASE}/bin/flex"
+USES= bison desktop-file-utils gmake iconv jpeg \
+ localbase perl5 pkgconfig shebangfix
+USE_GNOME= glib20 gtk20 librsvg2
-NSFB_VERSION= 0.1.0
-WRKSRC= ${WRKDIR}/${PORTNAME}-full-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
-DESKTOP_ENTRIES="NetSurf" "${COMMENT}" "${DATADIR}/${PORTNAME}.xpm" \
- "${PORTNAME}" "" true
+SHEBANG_FILES= utils/split-messages.pl
+perl_CMD= ${SETENV} perl
-OPTIONS_DEFINE= GSTREAMER WEBP
+OPTIONS_DEFINE= GSTREAMER
GSTREAMER_USE= GSTREAMER=yes
-WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} '/^NSFB_LINUX_AVAILABLE/ s|yes|no| ; s| -g||' \
- ${WRKSRC}/src/libnsfb-${NSFB_VERSION}/Makefile
- @${REINPLACE_CMD} 's|endian|sys/endian|' \
- ${WRKSRC}/src/libnsfb-${NSFB_VERSION}/src/plot/*bpp*.c
@${REINPLACE_CMD} '/CFLAGS/d' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/Makefile.defaults
+ ${WRKSRC}//Makefile.defaults
@${REINPLACE_CMD} 's| -O2||' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/gtk/Makefile.defaults
+ ${WRKSRC}/gtk/Makefile.defaults
@${REINPLACE_CMD} \
- -e '/OpenSSL/d' -e '/lcms/d' -e 's| -g||' \
+ -e '/OpenSSL/d' -e 's| -g||' \
-e 's/-DG_DISABLE_DEPRECATED//' \
- -e 's/-DGDK_PIXBUF_DISABLE_DEPRECATED//' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/gtk/Makefile.target
- @${REINPLACE_CMD} -e 's| -g|| ; s|flex|${LOCALBASE}/bin/&|' \
- ${WRKSRC}/src/nsgenbind-0.0.1/src/Makefile
+ ${WRKSRC}/gtk/Makefile.target
do-configure:
- @${CP} ${FILESDIR}/Makefile.config ${WRKSRC}/src/netsurf-${PORTVERSION}
+ @${CP} ${FILESDIR}/Makefile.config ${WRKSRC}
.if empty(ICONV_LIB)
@${REINPLACE_CMD} '/NETSURF_USE_LIBICONV_PLUG/ s|NO|YES|' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/Makefile.config
+ ${WRKSRC}/Makefile.config
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
@${REINPLACE_CMD} '/NETSURF_USE_VIDEO/ s|NO|YES|' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/Makefile.config
+ ${WRKSRC}/Makefile.config
.endif
-.if ${PORT_OPTIONS:MWEBP}
- @${REINPLACE_CMD} '/NETSURF_USE_WEBP/ s|NO|YES|' \
- ${WRKSRC}/src/netsurf-${PORTVERSION}/Makefile.config
-.endif
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/netsurf
.include <bsd.port.post.mk>
diff --git a/www/netsurf/distinfo b/www/netsurf/distinfo
index f2d65dbbba98..68f30f2c0a5d 100644
--- a/www/netsurf/distinfo
+++ b/www/netsurf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netsurf-3.0-full-src.tar.gz) = 5c4467b921d24a8702bfb20875b0eee3ff38707c7e623f24f92eff0b3ba6d6a0
-SIZE (netsurf-3.0-full-src.tar.gz) = 6143522
+SHA256 (netsurf-3.4-src.tar.gz) = 1648f437994fc18090237430f30d645ff06bab0768ae973575f9391d07613bf6
+SIZE (netsurf-3.4-src.tar.gz) = 4133201
diff --git a/www/netsurf/files/Makefile.config b/www/netsurf/files/Makefile.config
index ecce146b92ac..60c2e1328a0c 100644
--- a/www/netsurf/files/Makefile.config
+++ b/www/netsurf/files/Makefile.config
@@ -1,7 +1,5 @@
-NETSURF_USE_HARU_PDF=NO
NETSURF_USE_LIBICONV_PLUG=NO
-NETSURF_USE_MNG=NO
NETSURF_USE_NSSVG=NO
-NETSURF_USE_ROSPRITE=NO
+NETSURF_USE_RSVG=YES
NETSURF_USE_VIDEO=NO
-NETSURF_USE_WEBP=NO
+NETSURF_STRIP_BINARY=YES
diff --git a/www/netsurf/files/patch-gtk_Makefile.target b/www/netsurf/files/patch-gtk_Makefile.target
new file mode 100644
index 000000000000..cc4cbf4d9bc9
--- /dev/null
+++ b/www/netsurf/files/patch-gtk_Makefile.target
@@ -0,0 +1,15 @@
+--- gtk/Makefile.target.orig 2016-02-16 13:30:38 UTC
++++ gtk/Makefile.target
+@@ -210,7 +210,11 @@ GTK_TRANSLATIONS_HTML := de en fr it ja
+
+ install-gtk:
+ $(Q)mkdir -p $(DESTDIR)$(NETSURF_GTK_BIN)
+- $(Q)install nsgtk $(DESTDIR)$(NETSURF_GTK_BIN)netsurf
++ $(Q)install nsgtk $(DESTDIR)$(NETSURF_GTK_BIN)netsurf-gtk
++ $(Q)mkdir -p $(DESTDIR)$(PREFIX)/share/applications
++ $(Q)install -m 0644 gtk/res/*.desktop $(DESTDIR)$(PREFIX)/share/applications/netsurf.desktop
++ $(Q)mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
++ $(Q)install -m 0644 gtk/res/netsurf.xpm $(DESTDIR)$(PREFIX)/share/pixmaps
+ $(Q)mkdir -p $(DESTDIR)$(NETSURF_GTK_RESOURCES)icons
+ $(Q)install -m 0644 gtk/res/icons/*.png $(DESTDIR)$(NETSURF_GTK_RESOURCES)/icons
+ $(Q)mkdir -p $(DESTDIR)$(NETSURF_GTK_RESOURCES)throbber
diff --git a/www/netsurf/files/patch-pixel-format b/www/netsurf/files/patch-pixel-format
deleted file mode 100644
index d0cb658d42f3..000000000000
--- a/www/netsurf/files/patch-pixel-format
+++ /dev/null
@@ -1,89 +0,0 @@
---- src/netsurf-3.0/gtk/bitmap.c.orig
-+++ src/netsurf-3.0/gtk/bitmap.c
-@@ -288,27 +288,27 @@
-
- if (fmt == CAIRO_FORMAT_RGB24) {
- for (pixel_loop=0; pixel_loop < pixel_count; pixel_loop++) {
-- pixel = pixels[pixel_loop];
-- pixels[pixel_loop] = (pixel & 0xff00ff00) |
-- ((pixel & 0xff) << 16) |
-- ((pixel & 0xff0000) >> 16);
-+ pixel = ((uint8_t *)(pixels + pixel_loop))[0] << 16 |
-+ ((uint8_t *)(pixels + pixel_loop))[1] << 8 |
-+ ((uint8_t *)(pixels + pixel_loop))[2] |
-+ ((uint8_t *)(pixels + pixel_loop))[3] << 24;
-+ pixels[pixel_loop] = pixel;
- }
- } else {
- uint8_t t, r, g, b;
- for (pixel_loop=0; pixel_loop < pixel_count; pixel_loop++) {
-- pixel = pixels[pixel_loop];
-- t = (pixel & 0xff000000) >> 24;
-+ t = ((uint8_t *)(pixels + pixel_loop))[3];
- if (t == 0) {
- pixels[pixel_loop] = 0;
- } else {
-- r = (pixel & 0xff0000) >> 16;
-- g = (pixel & 0xff00) >> 8;
-- b = pixel & 0xff;
-+ r = ((uint8_t *)(pixels + pixel_loop))[0];
-+ g = ((uint8_t *)(pixels + pixel_loop))[1];
-+ b = ((uint8_t *)(pixels + pixel_loop))[2];
-
- pixels[pixel_loop] = (t << 24) |
-- ((r * t) >> 8) |
-+ ((r * t) >> 8) << 16 |
- ((g * t) >> 8) << 8 |
-- ((b * t) >> 8) << 16;
-+ ((b * t) >> 8);
-
- }
- }
---- src/netsurf-3.0/image/bmp.c.orig
-+++ src/netsurf-3.0/image/bmp.c
-@@ -171,7 +171,6 @@
-
- /* exit as a success */
- bmp->bitmap = bmp->bmp->bitmap;
-- bitmap_modified(bmp->bitmap);
-
- content_set_ready(c);
- content_set_done(c);
-@@ -190,6 +189,8 @@
- if (bmp->bmp->decoded == false)
- if (bmp_decode(bmp->bmp) != BMP_OK)
- return false;
-+ else
-+ bitmap_modified(bmp->bitmap);
-
- bmp->bitmap = bmp->bmp->bitmap;
-
---- src/netsurf-3.0/image/rsvg.c.orig
-+++ src/netsurf-3.0/image/rsvg.c
-@@ -135,19 +135,17 @@
- static inline void rsvg_argb_to_abgr(uint8_t *pixels,
- int width, int height, size_t rowstride)
- {
-- uint8_t *p = pixels;
-+ uint32_t *p = (uint32_t *)pixels;
-
- for (int y = 0; y < height; y++) {
- for (int x = 0; x < width; x++) {
-- /* Swap R and B */
-- const uint8_t r = p[x+3];
--
-- p[x+3] = p[x];
--
-- p[x] = r;
-+ uint32_t c = *p;
-+ ((uint8_t *)p)[0] = (c & 0xff0000) >> 16;
-+ ((uint8_t *)p)[1] = (c & 0xff00) >> 8;
-+ ((uint8_t *)p)[2] = (c & 0xff);
-+ ((uint8_t *)p)[3] = (c & 0xff000000) >> 24;
-+ p++;
- }
--
-- p += rowstride;
- }
- }
-
diff --git a/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__nsgenbind-lexer.l b/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__nsgenbind-lexer.l
deleted file mode 100644
index b13b64a2f476..000000000000
--- a/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__nsgenbind-lexer.l
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./src/nsgenbind-0.0.1/src/nsgenbind-lexer.l.orig 2013-04-18 23:59:18.000000000 +0200
-+++ ./src/nsgenbind-0.0.1/src/nsgenbind-lexer.l 2013-06-13 18:54:25.000000000 +0200
-@@ -19,6 +19,16 @@
- yylloc->first_column = yylloc->last_column + 1; \
- yylloc->last_column += yyleng;
-
-+
-+/* Ensure compatability with bison 2.6 and later */
-+#if ! defined YYSTYPE && ! defined YYSTYPE_IS_DECLARED && defined NSGENBIND_STYPE_IS_DECLARED
-+#define YYSTYPE NSGENBIND_STYPE
-+#endif
-+
-+#if ! defined YYLTYPE && ! defined YYLTYPE_IS_DECLARED && defined NSGENBIND_LTYPE_IS_DECLARED
-+#define YYLTYPE NSGENBIND_LTYPE
-+#endif
-+
- %}
-
- /* lexer options */
diff --git a/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__webidl-lexer.l b/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__webidl-lexer.l
deleted file mode 100644
index 0f4464a9d6a1..000000000000
--- a/www/netsurf/files/patch-src__nsgenbind-0.0.1__src__webidl-lexer.l
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/nsgenbind-0.0.1/src/webidl-lexer.l.orig 2013-04-18 23:59:18.000000000 +0200
-+++ ./src/nsgenbind-0.0.1/src/webidl-lexer.l 2013-06-13 18:54:25.000000000 +0200
-@@ -27,6 +27,15 @@
- yylloc->first_column = yylloc->last_column + 1; \
- yylloc->last_column += yyleng;
-
-+/* Ensure compatability with bison 2.6 and later */
-+#if ! defined YYSTYPE && ! defined YYSTYPE_IS_DECLARED && defined WEBIDL_STYPE_IS_DECLARED
-+#define YYSTYPE WEBIDL_STYPE
-+#endif
-+
-+#if ! defined YYLTYPE && ! defined YYLTYPE_IS_DECLARED && defined WEBIDL_LTYPE_IS_DECLARED
-+#define YYLTYPE WEBIDL_LTYPE
-+#endif
-+
- %}
-
-
diff --git a/www/netsurf/pkg-plist b/www/netsurf/pkg-plist
index f529c96bc5ef..a80972737279 100644
--- a/www/netsurf/pkg-plist
+++ b/www/netsurf/pkg-plist
@@ -1,99 +1,99 @@
-bin/netsurf
-share/netsurf/SearchEngines
-share/netsurf/adblock.css
-share/netsurf/arrow_down_8x32.png
-share/netsurf/ca-bundle.txt
-share/netsurf/cookies.gtk2.ui
-share/netsurf/cookies.gtk3.ui
-share/netsurf/de/Messages
-share/netsurf/de/welcome.html
-share/netsurf/default.css
-share/netsurf/default.ico
-share/netsurf/downloads.gtk2.ui
-share/netsurf/downloads.gtk3.ui
-share/netsurf/en/Messages
-share/netsurf/en/credits.html
-share/netsurf/en/licence.html
-share/netsurf/en/welcome.html
-share/netsurf/favicon.png
-share/netsurf/fr/Messages
-share/netsurf/gtkdefault.css
-share/netsurf/history.gtk2.ui
-share/netsurf/history.gtk3.ui
-share/netsurf/hotlist.gtk2.ui
-share/netsurf/hotlist.gtk3.ui
-share/netsurf/icons/content.png
-share/netsurf/icons/directory.png
-share/netsurf/icons/search.png
-share/netsurf/internal.css
-share/netsurf/it/Messages
-share/netsurf/it/credits.html
-share/netsurf/it/licence.html
-share/netsurf/it/welcome.html
-share/netsurf/ja/welcome.html
-share/netsurf/languages
-share/netsurf/license
-share/netsurf/login.gtk2.ui
-share/netsurf/login.gtk3.ui
-share/netsurf/netsurf-16x16.xpm
-share/netsurf/netsurf.gtk2.ui
-share/netsurf/netsurf.gtk3.ui
-share/netsurf/netsurf.png
-share/netsurf/netsurf.xpm
-share/netsurf/nl/Messages
-share/netsurf/options.gtk2.ui
-share/netsurf/options.gtk3.ui
-share/netsurf/password.gtk2.ui
-share/netsurf/password.gtk3.ui
-share/netsurf/quirks.css
-share/netsurf/source.gtk2.ui
-share/netsurf/source.gtk3.ui
-share/netsurf/ssl.gtk2.ui
-share/netsurf/ssl.gtk3.ui
-share/netsurf/tabcontents.gtk2.ui
-share/netsurf/tabcontents.gtk3.ui
-share/netsurf/themelist
-share/netsurf/themes/Alpha.png
-share/netsurf/themes/gtk+/back.png
-share/netsurf/themes/gtk+/closetab.png
-share/netsurf/themes/gtk+/closewindow.png
-share/netsurf/themes/gtk+/copy.png
-share/netsurf/themes/gtk+/cut.png
-share/netsurf/themes/gtk+/delete.png
-share/netsurf/themes/gtk+/forward.png
-share/netsurf/themes/gtk+/fullscreen.png
-share/netsurf/themes/gtk+/helpabout.png
-share/netsurf/themes/gtk+/helpcontents.png
-share/netsurf/themes/gtk+/history.png
-share/netsurf/themes/gtk+/home.png
-share/netsurf/themes/gtk+/info
-share/netsurf/themes/gtk+/newtab.png
-share/netsurf/themes/gtk+/newwindow.png
-share/netsurf/themes/gtk+/openfile.png
-share/netsurf/themes/gtk+/paste.png
-share/netsurf/themes/gtk+/preferences.png
-share/netsurf/themes/gtk+/print.png
-share/netsurf/themes/gtk+/printpreview.png
-share/netsurf/themes/gtk+/quit.png
-share/netsurf/themes/gtk+/reload.png
-share/netsurf/themes/gtk+/savepage.png
-share/netsurf/themes/gtk+/selectall.png
-share/netsurf/themes/gtk+/stop.png
-share/netsurf/themes/gtk+/viewsource.png
-share/netsurf/themes/gtk+/zoomminus.png
-share/netsurf/themes/gtk+/zoomnormal.png
-share/netsurf/themes/gtk+/zoomplus.png
-share/netsurf/throbber/throbber0.png
-share/netsurf/throbber/throbber1.png
-share/netsurf/throbber/throbber2.png
-share/netsurf/throbber/throbber3.png
-share/netsurf/throbber/throbber4.png
-share/netsurf/throbber/throbber5.png
-share/netsurf/throbber/throbber6.png
-share/netsurf/throbber/throbber7.png
-share/netsurf/throbber/throbber8.png
-share/netsurf/toolbar.gtk2.ui
-share/netsurf/toolbar.gtk3.ui
-share/netsurf/toolbarIndices
-share/netsurf/warning.gtk2.ui
-share/netsurf/warning.gtk3.ui
+bin/netsurf-gtk
+share/applications/netsurf.desktop
+%%DATADIR%%/Messages
+%%DATADIR%%/SearchEngines
+%%DATADIR%%/adblock.css
+%%DATADIR%%/arrow_down_8x32.png
+%%DATADIR%%/ca-bundle.txt
+%%DATADIR%%/cookies.gtk2.ui
+%%DATADIR%%/credits.html
+%%DATADIR%%/de/Messages
+%%DATADIR%%/de/welcome.html
+%%DATADIR%%/default.css
+%%DATADIR%%/default.ico
+%%DATADIR%%/downloads.gtk2.ui
+%%DATADIR%%/en/Messages
+%%DATADIR%%/en/credits.html
+%%DATADIR%%/en/licence.html
+%%DATADIR%%/en/maps.html
+%%DATADIR%%/en/welcome.html
+%%DATADIR%%/favicon.png
+%%DATADIR%%/fr/Messages
+%%DATADIR%%/history.gtk2.ui
+%%DATADIR%%/hotlist.gtk2.ui
+%%DATADIR%%/icons/arrow-l.png
+%%DATADIR%%/icons/content.png
+%%DATADIR%%/icons/directory.png
+%%DATADIR%%/icons/directory2.png
+%%DATADIR%%/icons/hotlist-add.png
+%%DATADIR%%/icons/hotlist-rmv.png
+%%DATADIR%%/icons/search.png
+%%DATADIR%%/internal.css
+%%DATADIR%%/it/Messages
+%%DATADIR%%/it/credits.html
+%%DATADIR%%/it/licence.html
+%%DATADIR%%/it/welcome.html
+%%DATADIR%%/ja/welcome.html
+%%DATADIR%%/languages
+%%DATADIR%%/licence.html
+%%DATADIR%%/login.gtk2.ui
+%%DATADIR%%/maps.html
+%%DATADIR%%/netsurf-16x16.xpm
+%%DATADIR%%/netsurf.gtk2.ui
+%%DATADIR%%/netsurf.png
+%%DATADIR%%/netsurf.xpm
+%%DATADIR%%/nl/Messages
+%%DATADIR%%/nl/credits.html
+%%DATADIR%%/nl/licence.html
+%%DATADIR%%/nl/welcome.html
+%%DATADIR%%/options.gtk2.ui
+%%DATADIR%%/password.gtk2.ui
+%%DATADIR%%/quirks.css
+%%DATADIR%%/ssl.gtk2.ui
+%%DATADIR%%/tabcontents.gtk2.ui
+%%DATADIR%%/themelist
+%%DATADIR%%/themes/Alpha.png
+%%DATADIR%%/themes/gtk+/back.png
+%%DATADIR%%/themes/gtk+/closetab.png
+%%DATADIR%%/themes/gtk+/closewindow.png
+%%DATADIR%%/themes/gtk+/copy.png
+%%DATADIR%%/themes/gtk+/cut.png
+%%DATADIR%%/themes/gtk+/delete.png
+%%DATADIR%%/themes/gtk+/forward.png
+%%DATADIR%%/themes/gtk+/fullscreen.png
+%%DATADIR%%/themes/gtk+/helpabout.png
+%%DATADIR%%/themes/gtk+/helpcontents.png
+%%DATADIR%%/themes/gtk+/history.png
+%%DATADIR%%/themes/gtk+/home.png
+%%DATADIR%%/themes/gtk+/info
+%%DATADIR%%/themes/gtk+/newtab.png
+%%DATADIR%%/themes/gtk+/newwindow.png
+%%DATADIR%%/themes/gtk+/openfile.png
+%%DATADIR%%/themes/gtk+/paste.png
+%%DATADIR%%/themes/gtk+/preferences.png
+%%DATADIR%%/themes/gtk+/print.png
+%%DATADIR%%/themes/gtk+/printpreview.png
+%%DATADIR%%/themes/gtk+/quit.png
+%%DATADIR%%/themes/gtk+/reload.png
+%%DATADIR%%/themes/gtk+/savepage.png
+%%DATADIR%%/themes/gtk+/selectall.png
+%%DATADIR%%/themes/gtk+/stop.png
+%%DATADIR%%/themes/gtk+/viewsource.png
+%%DATADIR%%/themes/gtk+/zoomminus.png
+%%DATADIR%%/themes/gtk+/zoomnormal.png
+%%DATADIR%%/themes/gtk+/zoomplus.png
+%%DATADIR%%/throbber/throbber0.png
+%%DATADIR%%/throbber/throbber1.png
+%%DATADIR%%/throbber/throbber2.png
+%%DATADIR%%/throbber/throbber3.png
+%%DATADIR%%/throbber/throbber4.png
+%%DATADIR%%/throbber/throbber5.png
+%%DATADIR%%/throbber/throbber6.png
+%%DATADIR%%/throbber/throbber7.png
+%%DATADIR%%/throbber/throbber8.png
+%%DATADIR%%/toolbar.gtk2.ui
+%%DATADIR%%/toolbarIndices
+%%DATADIR%%/viewdata.gtk2.ui
+%%DATADIR%%/warning.gtk2.ui
+%%DATADIR%%/welcome.html
+share/pixmaps/netsurf.xpm