aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/xombrero/Makefile2
-rw-r--r--www/xombrero/files/patch-freebsd__Makefile.232
2 files changed, 33 insertions, 1 deletions
diff --git a/www/xombrero/Makefile b/www/xombrero/Makefile
index 7f180c5f1c98..e79eb609731b 100644
--- a/www/xombrero/Makefile
+++ b/www/xombrero/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.6.4
CATEGORIES= www
MASTER_SITES= https://opensource.conformal.com/snapshots/xombrero/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rea@FreeBSD.org
COMMENT= Minimalists vi-like web browser based on webkit and GTK+
LICENSE= ISCL
diff --git a/www/xombrero/files/patch-freebsd__Makefile.2 b/www/xombrero/files/patch-freebsd__Makefile.2
new file mode 100644
index 000000000000..0d8237f5f81c
--- /dev/null
+++ b/www/xombrero/files/patch-freebsd__Makefile.2
@@ -0,0 +1,32 @@
+--- freebsd/Makefile.old 2016-12-25 23:58:00.917123000 +0300
++++ freebsd/Makefile 2016-12-25 23:58:00.917136000 +0300
+@@ -20,6 +20,11 @@
+
+ CC?= cc
+
++PARENT_OBJS= \
++ ../xombrero.o freebsd.o ../marco.o ../about.o ../inspector.o ../whitelist.o \
++ ../settings.o ../cookie.o ../history.o ../completion.o ../inputfocus.o ../tldlist.o \
++ ../externaleditor.o ../unix.o
++
+ all: ../javascript.h ../tooltip.h xombrero
+
+ ../javascript.h: ../js-merge-helper.pl ../hinting.js ../autoscroll.js
+@@ -57,11 +62,13 @@
+
+ tldlist.o: ../tldlist.o
+
+-../xombrero.o: ../javascript.h ../tooltip.h
++../settings.o: ../tooltip.h
+
+-xombrero: ../xombrero.o freebsd.o ../marco.o ../about.o ../inspector.o ../whitelist.o \
+- ../settings.o ../cookie.o ../history.o ../completion.o ../inputfocus.o ../tldlist.o \
+- ../externaleditor.o ../unix.o
++$(PARENT_OBJS): ../xombrero.h
++
++../xombrero.h: ../javascript.h
++
++xombrero: freebsd.o $(PARENT_OBJS)
+ $(CC) $(LDFLAGS) -o $@ ${.ALLSRC} $(LDADD)
+
+ install: all