aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/neon28/Makefile20
-rw-r--r--www/neon29/Makefile20
2 files changed, 24 insertions, 16 deletions
diff --git a/www/neon28/Makefile b/www/neon28/Makefile
index bd5132d87038..1bb0fb7c1067 100644
--- a/www/neon28/Makefile
+++ b/www/neon28/Makefile
@@ -22,14 +22,6 @@ CONFLICTS= neon26-[0-9]*
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
.endif
@@ -42,6 +34,18 @@ CONFIGURE_ARGS= --with-ssl \
--with-expat \
--with-libs=${LOCALBASE}:${PREFIX}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--without-gssapi
+.endif
+
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_resolve.3 ne_buffer.3 \
ne_buffer_append.3 ne_buffer_clear.3 ne_buffer_create.3 \
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index bd5132d87038..1bb0fb7c1067 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -22,14 +22,6 @@ CONFLICTS= neon26-[0-9]*
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
.endif
@@ -42,6 +34,18 @@ CONFIGURE_ARGS= --with-ssl \
--with-expat \
--with-libs=${LOCALBASE}:${PREFIX}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--without-gssapi
+.endif
+
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_resolve.3 ne_buffer.3 \
ne_buffer_append.3 ne_buffer_clear.3 ne_buffer_create.3 \