aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/httpsqs/Makefile3
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/openvrml/Makefile4
4 files changed, 5 insertions, 6 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index a3aebe09e606..35621fc528e7 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -156,7 +156,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-openssl-9.8up.patch
.endif
.if ${OSVERSION} < 700014 && ${ARCH} == i386
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
.endif
.if defined(WITH_THREADS)
diff --git a/www/httpsqs/Makefile b/www/httpsqs/Makefile
index a9fe50fb32b3..68ecfb0b1e37 100644
--- a/www/httpsqs/Makefile
+++ b/www/httpsqs/Makefile
@@ -18,8 +18,7 @@ LICENSE= BSD
LIB_DEPENDS+= tokyocabinet:${PORTSDIR}/databases/tokyocabinet \
event-2.0:${PORTSDIR}/devel/libevent2
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
-
+USE_PKGCONFIG= yes
MAKE_ENV= LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/${PORTNAME}
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 1a1ab0e6eaef..05b6bd1e43e1 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -19,13 +19,13 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
.endif
-BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_GMAKE= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
#.if !defined(_BUILDING_LIGHTTPD_MODULE)
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 3cc64174ea14..d62648c771dd 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= VRML97 runtime and browser
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
- pkg-config:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
js.1:${PORTSDIR}/lang/spidermonkey \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -28,6 +27,7 @@ USE_GNOME= gnomehack libglade2 libgnomeui
USE_SDL= sdl
USE_JAVA= yes
USE_GCC= 4.6+
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
LIBTOOLFILES= configure
CONFIGURE_ARGS= --enable-gecko-rpath \