aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/webcalendar-devel/Makefile103
-rw-r--r--www/webcalendar-devel/distinfo6
-rw-r--r--www/webcalendar-devel/files/pkg-message.in19
-rw-r--r--www/webcalendar-devel/files/webcalendar-cgi.conf.in19
-rw-r--r--www/webcalendar-devel/files/webcalendar.conf.in16
-rw-r--r--www/webcalendar-devel/pkg-descr8
-rw-r--r--www/webcalendar-devel/pkg-plist431
7 files changed, 559 insertions, 43 deletions
diff --git a/www/webcalendar-devel/Makefile b/www/webcalendar-devel/Makefile
index 5a7e8d1557be..80a2adcc30ee 100644
--- a/www/webcalendar-devel/Makefile
+++ b/www/webcalendar-devel/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= WebCalendar
-PORTVERSION= 1.1.6
+PORTVERSION= 1.2.b1
CATEGORIES= www
MASTER_SITES= SF
-MASTER_SITE_SUBDIR= webcalendar
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME:S/-devel//g}-${PORTVERSION}
@@ -22,19 +22,16 @@ NO_BUILD= yes
CONFLICTS= WebCalendar-[0-9]*
WRKSRC= ${WRKDIR}/${DISTNAME}
+WWWDIR= ${PREFIX}/www/${PORTNAME:L}
-WCURL?= ${MASTER_SITE_SUBDIR}
-WCDIR?= www/${WCURL}
-PLIST= ${WRKDIR}/pkg-plist
-
-SUB_FILES= pkg-message
-SUB_LIST= WCURL=${WCURL} WCDIR=${WCDIR}
-
-DOCSDIR?= ${PREFIX}/share/doc/${MASTER_SITE_SUBDIR}
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:L}
PORTDOCS= WebCalendar-SysAdmin.html \
newwin.gif
+.endif
-OPTIONS= MYSQL "Use MySQL database backend (default)" On \
+OPTIONS= APACHE "Configure for Apache-2.x" off \
+ MYSQL "Use MySQL database backend (default)" On \
PGSQL "Use PostgreSQL database backend" Off \
MSSQL "Use MSSQL database backend" Off \
DBASE "Use DBase database backend" Off \
@@ -42,10 +39,34 @@ OPTIONS= MYSQL "Use MySQL database backend (default)" On \
ORACLE "Use Oracle database backend" Off \
LDAP "Use LDAP user authentication" Off \
GRADIENTBG "Add gradient background image support" Off \
- REMINDERS "Add email reminder support" On
+ REMINDERS "Add email reminder support" On \
+ PALM "Add Palm export support" Off
.include <bsd.port.pre.mk>
+.if defined(WITH_APACHE)
+USE_APACHE= 2.0+
+
+PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
+CONFDIR= ${PREFIX}/${CONFDIR_REL}
+CONFDIR_REL= ${APACHEETCDIR}/Includes
+SUB_FILES= pkg-message
+.else
+PLIST_SUB+= NOAPACHE="@comment "
+.endif
+
+WITH_PHP_CGI?= /cgi-bin/php
+
+.if ${PHP_SAPI:Mcgi} == "cgi" && ${PHP_SAPI:Mmod} == ""
+CGI_EXT= -cgi
+.else
+CGI_EXT=
+.endif
+
+DEFAULT_PHP_VER=5
+
+SUB_LIST+= PHPCGI=${WITH_PHP_CGI}
+
DB_DEFINED= no
.if !defined(WITHOUT_MYSQL)
@@ -94,27 +115,59 @@ USE_PHP+= gd
WANT_PHP_CLI= yes
.endif
-pre-install:
- cd ${WRKSRC} && ${FIND} -s * -type f | \
- ${SED} -e 's|^|${WCDIR}/|' > ${PLIST} \
- && ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${WCDIR}/|' >> ${PLIST} \
- && ${ECHO_CMD} @dirrm ${WCDIR} >> ${PLIST}
- @${ECHO_CMD} @dirrmtry www/data-dist >> ${PLIST}
- @${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
+.if defined(WITH_PALM)
+RUN_DEPENDS+= ${LOCALBASE}/bin/pilot-xfer:${PORTSDIR}/palm/pilot-link
+.endif
+
+.if defined(NOPORTDOCS)
+SUB_LIST+= HASHMARK=\#
+.else
+SUB_LIST+= HASHMARK=
+.endif
+
+CONF= webcalendar${CGI_EXT}.conf
+SUB_FILES+= ${CONF}
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${WCDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WCDIR}
- @${FIND} ${PREFIX}/${WCDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
@${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
- ${WCDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
+ ${WWWDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
post-install:
+.if defined(WITH_APACHE)
+ @if [ -d "${CONFDIR}" ]; then \
+ ${CP} ${WRKDIR}/${CONF} ${CONFDIR}/webcalendar.conf; \
+ else \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please check your Apache 2.x installation -" ; \
+ ${ECHO_MSG} "${CONFDIR} doesn't exist," ; \
+ ${ECHO_MSG} "so I cannot install webcalendar.conf there!" ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+ @${CAT} ${PKGMESSAGE}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
+.if ${CGI_EXT} == "-cgi"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Your WebCalendar installation was configured to use the PHP CGI binary."
+ @${ECHO_MSG} "The PHP CGI binary is expected to be referenced by the URL:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " ${WITH_PHP_CGI}"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If this is incorrect, reinstall the port with the WITH_ PHP_CGI knob"
+ @${ECHO_MSG} "set to the correct URL."
+ @${ECHO_MSG} "*********************************************************************"
+.endif
.include <bsd.port.post.mk>
diff --git a/www/webcalendar-devel/distinfo b/www/webcalendar-devel/distinfo
index 47d467a67ec0..021f0014866a 100644
--- a/www/webcalendar-devel/distinfo
+++ b/www/webcalendar-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (WebCalendar-1.1.6.tar.gz) = 1a9e80abd7373008e0b998525dd03404
-SHA256 (WebCalendar-1.1.6.tar.gz) = ea8ede2a7ce74a3f5c72a7039ec5db6f6ee8db80e8a461f79cd493f16ac87d42
-SIZE (WebCalendar-1.1.6.tar.gz) = 1300618
+MD5 (WebCalendar-1.2.b1.tar.gz) = df1f4f24ddc88a536390e4ff9f53454b
+SHA256 (WebCalendar-1.2.b1.tar.gz) = dd13ea9f73a903db6793b543b70b26207e02aa74160747dddcec5f8ee6f83a37
+SIZE (WebCalendar-1.2.b1.tar.gz) = 1395741
diff --git a/www/webcalendar-devel/files/pkg-message.in b/www/webcalendar-devel/files/pkg-message.in
index cf55974b4b30..2df6ae03b6e2 100644
--- a/www/webcalendar-devel/files/pkg-message.in
+++ b/www/webcalendar-devel/files/pkg-message.in
@@ -1,14 +1,13 @@
-*************************************************
-Post-installation instructions:
-First, add the following line to your httpd.conf:
+*********************************************************************
+You have just installed the WebCalendar application.
-Alias /%%WCURL%%/ "%%PREFIX%%/%%WCDIR%%/"
+Note that you should restart your Apache web server to ensure that
+the WebCalendar configuration file is loaded.
-Make sure to restart your web server after changing
-httpd.conf.
+Next, to configure WebCalendar, please visit:
-Next, to configure WebCalendar, please visit
-http://localhost/%%WCURL%%/ and you will
-be guided through the installation process.
-*************************************************
+ http://localhost/webcalendar/
+
+and you will be guided through the installation process.
+*********************************************************************
diff --git a/www/webcalendar-devel/files/webcalendar-cgi.conf.in b/www/webcalendar-devel/files/webcalendar-cgi.conf.in
new file mode 100644
index 000000000000..e3de2eb3da4e
--- /dev/null
+++ b/www/webcalendar-devel/files/webcalendar-cgi.conf.in
@@ -0,0 +1,19 @@
+AddType application/x-httpd-php .php
+AddType application/x-httpd-php-source .phps
+DirectoryIndex index.php index.html
+
+Action php-script %%PHPCGI%%
+AddHandler php-script .php
+
+%%HASHMARK%%Alias /webcalendar/docs %%DOCSDIR%%
+Alias /webcalendar %%WWWDIR%%
+
+%%HASHMARK%%<Directory %%DOCSDIR%%>
+%%HASHMARK%% Order deny,allow
+%%HASHMARK%% Allow from all
+%%HASHMARK%%</Directory>
+
+<Location /webcalendar>
+ Order deny,allow
+ Allow from all
+</Location>
diff --git a/www/webcalendar-devel/files/webcalendar.conf.in b/www/webcalendar-devel/files/webcalendar.conf.in
new file mode 100644
index 000000000000..13b6c82bdbd3
--- /dev/null
+++ b/www/webcalendar-devel/files/webcalendar.conf.in
@@ -0,0 +1,16 @@
+AddType application/x-httpd-php .php
+AddType application/x-httpd-php-source .phps
+DirectoryIndex index.php index.html
+
+%%HASHMARK%%Alias /webcalendar/docs %%DOCSDIR%%
+Alias /webcalendar %%WWWDIR%%
+
+%%HASHMARK%%<Directory %%DOCSDIR%%>
+%%HASHMARK%% Order deny,allow
+%%HASHMARK%% Allow from all
+%%HASHMARK%%</Directory>
+
+<Location /webcalendar>
+ Order deny,allow
+ Allow from all
+</Location>
diff --git a/www/webcalendar-devel/pkg-descr b/www/webcalendar-devel/pkg-descr
index 7bee540983fb..bbb4ec7834b2 100644
--- a/www/webcalendar-devel/pkg-descr
+++ b/www/webcalendar-devel/pkg-descr
@@ -1,8 +1,6 @@
This is a port of the WebCalendar application. WebCalendar is an
Open Source web-based calendar/scheduling system written in PHP.
-WebCalendar has been under development since 2000 and continues
-to evolve.
+WebCalendar has been under development since 2000 and continues to
+evolve.
-WWW: http://www.k5n.us/webcalendar.php
-- Greg Larkin
-glarkin@sourcehosting.net
+WWW: http://www.k5n.us/webcalendar.php
diff --git a/www/webcalendar-devel/pkg-plist b/www/webcalendar-devel/pkg-plist
new file mode 100644
index 000000000000..642fe77ed8d8
--- /dev/null
+++ b/www/webcalendar-devel/pkg-plist
@@ -0,0 +1,431 @@
+%%NOAPACHE%%%%CONFDIR%%/webcalendar.conf
+%%WWWDIR%%/AUTHORS
+%%WWWDIR%%/GPL.html
+%%WWWDIR%%/NEWS
+%%WWWDIR%%/README.html
+%%WWWDIR%%/TODO
+%%WWWDIR%%/UPGRADING.html
+%%WWWDIR%%/about.php
+%%WWWDIR%%/access.php
+%%WWWDIR%%/activity_log.php
+%%WWWDIR%%/add_entry.php
+%%WWWDIR%%/admin.php
+%%WWWDIR%%/adminhome.php
+%%WWWDIR%%/ajax.php
+%%WWWDIR%%/approve_entry.php
+%%WWWDIR%%/assistant_edit.php
+%%WWWDIR%%/assistant_edit_handler.php
+%%WWWDIR%%/availability.php
+%%WWWDIR%%/category.php
+%%WWWDIR%%/category_handler.php
+%%WWWDIR%%/catsel.php
+%%WWWDIR%%/colors.php
+%%WWWDIR%%/controlpanel.php
+%%WWWDIR%%/css_cacher.php
+%%WWWDIR%%/datesel.php
+%%WWWDIR%%/day.php
+%%WWWDIR%%/del_entry.php
+%%WWWDIR%%/del_layer.php
+%%WWWDIR%%/doc.php
+%%WWWDIR%%/docadd.php
+%%WWWDIR%%/docdel.php
+%%WWWDIR%%/docs/WebCalendar-SysAdmin.html
+%%WWWDIR%%/docs/newwin.gif
+%%WWWDIR%%/edit_entry.php
+%%WWWDIR%%/edit_entry_handler.php
+%%WWWDIR%%/edit_layer.php
+%%WWWDIR%%/edit_layer_handler.php
+%%WWWDIR%%/edit_nonusers.php
+%%WWWDIR%%/edit_nonusers_handler.php
+%%WWWDIR%%/edit_remotes.php
+%%WWWDIR%%/edit_remotes_handler.php
+%%WWWDIR%%/edit_report.php
+%%WWWDIR%%/edit_report_handler.php
+%%WWWDIR%%/edit_template.php
+%%WWWDIR%%/edit_user.php
+%%WWWDIR%%/edit_user_handler.php
+%%WWWDIR%%/export.php
+%%WWWDIR%%/export_handler.php
+%%WWWDIR%%/favicon.ico
+%%WWWDIR%%/freebusy.php
+%%WWWDIR%%/group_edit.php
+%%WWWDIR%%/group_edit_handler.php
+%%WWWDIR%%/groups.php
+%%WWWDIR%%/help_admin.php
+%%WWWDIR%%/help_bug.php
+%%WWWDIR%%/help_docs.php
+%%WWWDIR%%/help_edit_entry.php
+%%WWWDIR%%/help_import.php
+%%WWWDIR%%/help_index.php
+%%WWWDIR%%/help_layers.php
+%%WWWDIR%%/help_pref.php
+%%WWWDIR%%/help_uac.php
+%%WWWDIR%%/icalclient.php
+%%WWWDIR%%/icons.php
+%%WWWDIR%%/icons/example.gif
+%%WWWDIR%%/images/arrow.gif
+%%WWWDIR%%/images/blank.gif
+%%WWWDIR%%/images/check.gif
+%%WWWDIR%%/images/circle.gif
+%%WWWDIR%%/images/colors.jpg
+%%WWWDIR%%/images/cross.gif
+%%WWWDIR%%/images/cursor.gif
+%%WWWDIR%%/images/delete.png
+%%WWWDIR%%/images/down.png
+%%WWWDIR%%/images/event.gif
+%%WWWDIR%%/images/firstmoon.gif
+%%WWWDIR%%/images/fullmoon.gif
+%%WWWDIR%%/images/help.gif
+%%WWWDIR%%/images/kn5.jpg
+%%WWWDIR%%/images/lastmoon.gif
+%%WWWDIR%%/images/leftarrow.gif
+%%WWWDIR%%/images/leftarrowsmall.gif
+%%WWWDIR%%/images/login.gif
+%%WWWDIR%%/images/new.gif
+%%WWWDIR%%/images/newmoon.gif
+%%WWWDIR%%/images/pix.gif
+%%WWWDIR%%/images/pixb.gif
+%%WWWDIR%%/images/register.gif
+%%WWWDIR%%/images/rejected.gif
+%%WWWDIR%%/images/rightarrow.gif
+%%WWWDIR%%/images/rightarrowsmall.gif
+%%WWWDIR%%/images/rss.png
+%%WWWDIR%%/images/select.gif
+%%WWWDIR%%/images/spacer.gif
+%%WWWDIR%%/images/task.gif
+%%WWWDIR%%/images/up.png
+%%WWWDIR%%/import.php
+%%WWWDIR%%/import_handler.php
+%%WWWDIR%%/import_outlookcsv.php
+%%WWWDIR%%/import_palmdesktop.php
+%%WWWDIR%%/includes/access.php
+%%WWWDIR%%/includes/assert.php
+%%WWWDIR%%/includes/blacklist.php
+%%WWWDIR%%/includes/classes/AttachmentList.class
+%%WWWDIR%%/includes/classes/CommentList.class
+%%WWWDIR%%/includes/classes/Doc.class
+%%WWWDIR%%/includes/classes/DocList.class
+%%WWWDIR%%/includes/classes/Event.class
+%%WWWDIR%%/includes/classes/RptEvent.class
+%%WWWDIR%%/includes/classes/WebCalMailer.class
+%%WWWDIR%%/includes/classes/WebCalendar.class
+%%WWWDIR%%/includes/classes/captcha/COLLEGE.ttf
+%%WWWDIR%%/includes/classes/captcha/README
+%%WWWDIR%%/includes/classes/captcha/README.webcalendar
+%%WWWDIR%%/includes/classes/captcha/captcha.php
+%%WWWDIR%%/includes/classes/hKit/hcal.profile.php
+%%WWWDIR%%/includes/classes/hKit/hkit.class.php
+%%WWWDIR%%/includes/classes/phpmailer/LICENSE
+%%WWWDIR%%/includes/classes/phpmailer/class.phpmailer.php
+%%WWWDIR%%/includes/classes/phpmailer/class.smtp.php
+%%WWWDIR%%/includes/common_admin_pref.php
+%%WWWDIR%%/includes/config.php
+%%WWWDIR%%/includes/date_formats.php
+%%WWWDIR%%/includes/dbi4php.php
+%%WWWDIR%%/includes/dbtable.php
+%%WWWDIR%%/includes/formvars.php
+%%WWWDIR%%/includes/functions.php
+%%WWWDIR%%/includes/gradient.php
+%%WWWDIR%%/includes/help_list.php
+%%WWWDIR%%/includes/index.html
+%%WWWDIR%%/includes/index.php
+%%WWWDIR%%/includes/init.php
+%%WWWDIR%%/includes/js/admin.php
+%%WWWDIR%%/includes/js/assistant_edit.php
+%%WWWDIR%%/includes/js/availability.php
+%%WWWDIR%%/includes/js/catsel.php
+%%WWWDIR%%/includes/js/colors.php
+%%WWWDIR%%/includes/js/edit_entry.php
+%%WWWDIR%%/includes/js/edit_layer.php
+%%WWWDIR%%/includes/js/edit_nonuser.php
+%%WWWDIR%%/includes/js/edit_remotes.php
+%%WWWDIR%%/includes/js/edit_user.php
+%%WWWDIR%%/includes/js/export_import.php
+%%WWWDIR%%/includes/js/popups.php
+%%WWWDIR%%/includes/js/pref.php
+%%WWWDIR%%/includes/js/prototype.js
+%%WWWDIR%%/includes/js/search.php
+%%WWWDIR%%/includes/js/set_entry_cat.php
+%%WWWDIR%%/includes/js/users.php
+%%WWWDIR%%/includes/js/usersel.php
+%%WWWDIR%%/includes/js/util.js
+%%WWWDIR%%/includes/js/view_d.php
+%%WWWDIR%%/includes/js/views_edit.php
+%%WWWDIR%%/includes/js/visible.php
+%%WWWDIR%%/includes/js/weekHover.js
+%%WWWDIR%%/includes/menu/JSCookMenu.js
+%%WWWDIR%%/includes/menu/icons/5days.png
+%%WWWDIR%%/includes/menu/icons/access.png
+%%WWWDIR%%/includes/menu/icons/add.png
+%%WWWDIR%%/includes/menu/icons/arrow.gif
+%%WWWDIR%%/includes/menu/icons/arrowdown.gif
+%%WWWDIR%%/includes/menu/icons/back.png
+%%WWWDIR%%/includes/menu/icons/blank.gif
+%%WWWDIR%%/includes/menu/icons/colorpicker.png
+%%WWWDIR%%/includes/menu/icons/config.png
+%%WWWDIR%%/includes/menu/icons/delete.png
+%%WWWDIR%%/includes/menu/icons/display.png
+%%WWWDIR%%/includes/menu/icons/document.png
+%%WWWDIR%%/includes/menu/icons/down.png
+%%WWWDIR%%/includes/menu/icons/edit.png
+%%WWWDIR%%/includes/menu/icons/edit2.png
+%%WWWDIR%%/includes/menu/icons/edit_add.png
+%%WWWDIR%%/includes/menu/icons/edit_remove.png
+%%WWWDIR%%/includes/menu/icons/exit.png
+%%WWWDIR%%/includes/menu/icons/find.png
+%%WWWDIR%%/includes/menu/icons/folder.png
+%%WWWDIR%%/includes/menu/icons/help.png
+%%WWWDIR%%/includes/menu/icons/help2.png
+%%WWWDIR%%/includes/menu/icons/home.png
+%%WWWDIR%%/includes/menu/icons/k5n.png
+%%WWWDIR%%/includes/menu/icons/layers.png
+%%WWWDIR%%/includes/menu/icons/list.png
+%%WWWDIR%%/includes/menu/icons/log.png
+%%WWWDIR%%/includes/menu/icons/mail_reply.png
+%%WWWDIR%%/includes/menu/icons/mail_send.png
+%%WWWDIR%%/includes/menu/icons/mail_send2.png
+%%WWWDIR%%/includes/menu/icons/manage_cal.png
+%%WWWDIR%%/includes/menu/icons/manage_reports.png
+%%WWWDIR%%/includes/menu/icons/manage_views.png
+%%WWWDIR%%/includes/menu/icons/mini/1day.png
+%%WWWDIR%%/includes/menu/icons/misc.png
+%%WWWDIR%%/includes/menu/icons/month.png
+%%WWWDIR%%/includes/menu/icons/new.png
+%%WWWDIR%%/includes/menu/icons/newtodo.png
+%%WWWDIR%%/includes/menu/icons/printer.png
+%%WWWDIR%%/includes/menu/icons/profile.png
+%%WWWDIR%%/includes/menu/icons/public.png
+%%WWWDIR%%/includes/menu/icons/reports.png
+%%WWWDIR%%/includes/menu/icons/search.png
+%%WWWDIR%%/includes/menu/icons/settings.png
+%%WWWDIR%%/includes/menu/icons/spacer.gif
+%%WWWDIR%%/includes/menu/icons/title_sm.png
+%%WWWDIR%%/includes/menu/icons/today.png
+%%WWWDIR%%/includes/menu/icons/todo.png
+%%WWWDIR%%/includes/menu/icons/unapproved.png
+%%WWWDIR%%/includes/menu/icons/up.png
+%%WWWDIR%%/includes/menu/icons/user.png
+%%WWWDIR%%/includes/menu/icons/users.png
+%%WWWDIR%%/includes/menu/icons/vcalendar.png
+%%WWWDIR%%/includes/menu/icons/vcard.png
+%%WWWDIR%%/includes/menu/icons/view_bottom.png
+%%WWWDIR%%/includes/menu/icons/view_choose.png
+%%WWWDIR%%/includes/menu/icons/view_detailed.png
+%%WWWDIR%%/includes/menu/icons/view_icon.png
+%%WWWDIR%%/includes/menu/icons/view_remove.png
+%%WWWDIR%%/includes/menu/icons/view_text.png
+%%WWWDIR%%/includes/menu/icons/viewmag.png
+%%WWWDIR%%/includes/menu/icons/views.png
+%%WWWDIR%%/includes/menu/icons/week.png
+%%WWWDIR%%/includes/menu/icons/year.png
+%%WWWDIR%%/includes/menu/index.php
+%%WWWDIR%%/includes/menu/menu_config.php
+%%WWWDIR%%/includes/menu/themes/autumn/theme.css
+%%WWWDIR%%/includes/menu/themes/autumn/theme.js
+%%WWWDIR%%/includes/menu/themes/darkness/arrow.gif
+%%WWWDIR%%/includes/menu/themes/darkness/arrowdown.gif
+%%WWWDIR%%/includes/menu/themes/darkness/theme.css
+%%WWWDIR%%/includes/menu/themes/darkness/theme.js
+%%WWWDIR%%/includes/menu/themes/default/theme.css
+%%WWWDIR%%/includes/menu/themes/default/theme.js
+%%WWWDIR%%/includes/menu/themes/office2003/mainmenubg.gif
+%%WWWDIR%%/includes/menu/themes/office2003/mainmenubg.png
+%%WWWDIR%%/includes/menu/themes/office2003/menubg.gif
+%%WWWDIR%%/includes/menu/themes/office2003/menubg.png
+%%WWWDIR%%/includes/menu/themes/office2003/theme.css
+%%WWWDIR%%/includes/menu/themes/office2003/theme.js
+%%WWWDIR%%/includes/menu/themes/spring/theme.css
+%%WWWDIR%%/includes/menu/themes/spring/theme.js
+%%WWWDIR%%/includes/menu/themes/touch_of_grey/theme.css
+%%WWWDIR%%/includes/menu/themes/touch_of_grey/theme.js
+%%WWWDIR%%/includes/menu/themes/touch_of_greydient/theme.css
+%%WWWDIR%%/includes/menu/themes/touch_of_greydient/theme.js
+%%WWWDIR%%/includes/moon_phases.php
+%%WWWDIR%%/includes/print_styles.css
+%%WWWDIR%%/includes/settings.php.orig
+%%WWWDIR%%/includes/site_extras.php
+%%WWWDIR%%/includes/styles.php
+%%WWWDIR%%/includes/trailer.php
+%%WWWDIR%%/includes/translate.php
+%%WWWDIR%%/includes/user-app-joomla.php
+%%WWWDIR%%/includes/user-app-postnuke.php
+%%WWWDIR%%/includes/user-imap.php
+%%WWWDIR%%/includes/user-ldap.php
+%%WWWDIR%%/includes/user-nis.php
+%%WWWDIR%%/includes/user.php
+%%WWWDIR%%/includes/validate.php
+%%WWWDIR%%/includes/views.php
+%%WWWDIR%%/includes/xcal.php
+%%WWWDIR%%/includes/zone.tab
+%%WWWDIR%%/index.php
+%%WWWDIR%%/install/default_config.php
+%%WWWDIR%%/install/index.php
+%%WWWDIR%%/install/install_functions.php
+%%WWWDIR%%/install/not_recommended.jpg
+%%WWWDIR%%/install/recommended.gif
+%%WWWDIR%%/install/sql/tables-db2.sql
+%%WWWDIR%%/install/sql/tables-ibase.sql
+%%WWWDIR%%/install/sql/tables-mssql.sql
+%%WWWDIR%%/install/sql/tables-mysql.sql
+%%WWWDIR%%/install/sql/tables-oracle.sql
+%%WWWDIR%%/install/sql/tables-postgres.sql
+%%WWWDIR%%/install/sql/tables-sqlite.php
+%%WWWDIR%%/install/sql/upgrade-db2.sql
+%%WWWDIR%%/install/sql/upgrade-ibase.sql
+%%WWWDIR%%/install/sql/upgrade-mssql.sql
+%%WWWDIR%%/install/sql/upgrade-mysql.sql
+%%WWWDIR%%/install/sql/upgrade-oracle.sql
+%%WWWDIR%%/install/sql/upgrade-postgres.sql
+%%WWWDIR%%/install/sql/upgrade_matrix.php
+%%WWWDIR%%/js_cacher.php
+%%WWWDIR%%/layers.php
+%%WWWDIR%%/layers_toggle.php
+%%WWWDIR%%/list_unapproved.php
+%%WWWDIR%%/login-app.php
+%%WWWDIR%%/login.php
+%%WWWDIR%%/minical.php
+%%WWWDIR%%/month.php
+%%WWWDIR%%/nonusers.php
+%%WWWDIR%%/nonusers_handler.php
+%%WWWDIR%%/nulogin.php
+%%WWWDIR%%/pref.php
+%%WWWDIR%%/publish.php
+%%WWWDIR%%/purge.php
+%%WWWDIR%%/register.php
+%%WWWDIR%%/reject_entry.php
+%%WWWDIR%%/remotes.php
+%%WWWDIR%%/report.php
+%%WWWDIR%%/rss.php
+%%WWWDIR%%/rss_unapproved.php
+%%WWWDIR%%/search.php
+%%WWWDIR%%/search_handler.php
+%%WWWDIR%%/select_user.php
+%%WWWDIR%%/set_entry_cat.php
+%%WWWDIR%%/tests/add_duration_test.php
+%%WWWDIR%%/tests/all_tests.php
+%%WWWDIR%%/themes/autumn_pref.gif
+%%WWWDIR%%/themes/autumn_pref.php
+%%WWWDIR%%/themes/basic_admin.gif
+%%WWWDIR%%/themes/basic_admin.php
+%%WWWDIR%%/themes/default_admin.php
+%%WWWDIR%%/themes/default_pref.gif
+%%WWWDIR%%/themes/default_pref.php
+%%WWWDIR%%/themes/spring_pref.gif
+%%WWWDIR%%/themes/spring_pref.php
+%%WWWDIR%%/themes/theme_inc.php
+%%WWWDIR%%/themes/touch_of_grey_pref.gif
+%%WWWDIR%%/themes/touch_of_grey_pref.php
+%%WWWDIR%%/tools/check_translation.pl
+%%WWWDIR%%/tools/convert_passwords.php
+%%WWWDIR%%/tools/palm_datebook.pl
+%%WWWDIR%%/tools/reload_remotes.php
+%%WWWDIR%%/tools/send_reminders.php
+%%WWWDIR%%/tools/summary.txt
+%%WWWDIR%%/tools/translation_summary.pl
+%%WWWDIR%%/tools/update_all.pl
+%%WWWDIR%%/tools/update_translation.pl
+%%WWWDIR%%/tools/upgrade_to_0.9.7.pl
+%%WWWDIR%%/translations/Afrikaans.txt
+%%WWWDIR%%/translations/Albanian.txt
+%%WWWDIR%%/translations/Arabic_utf8.txt
+%%WWWDIR%%/translations/Bahasa_Indonesia.txt
+%%WWWDIR%%/translations/Basque.txt
+%%WWWDIR%%/translations/Bulgarian.txt
+%%WWWDIR%%/translations/Catalan.txt
+%%WWWDIR%%/translations/Chinese-Big5.txt
+%%WWWDIR%%/translations/Chinese-GB2312.txt
+%%WWWDIR%%/translations/Croatian_utf8.txt
+%%WWWDIR%%/translations/Czech.txt
+%%WWWDIR%%/translations/Czech_utf8.txt
+%%WWWDIR%%/translations/Danish.txt
+%%WWWDIR%%/translations/Dutch.txt
+%%WWWDIR%%/translations/Elven.txt
+%%WWWDIR%%/translations/English-US.txt
+%%WWWDIR%%/translations/Estonian.txt
+%%WWWDIR%%/translations/Finnish.txt
+%%WWWDIR%%/translations/French-UTF8.txt
+%%WWWDIR%%/translations/French.txt
+%%WWWDIR%%/translations/Galician.txt
+%%WWWDIR%%/translations/German.txt
+%%WWWDIR%%/translations/German_utf8.txt
+%%WWWDIR%%/translations/Greek.txt
+%%WWWDIR%%/translations/Hebrew_utf8.txt
+%%WWWDIR%%/translations/Holo-Big5.txt
+%%WWWDIR%%/translations/Hungarian.txt
+%%WWWDIR%%/translations/Icelandic.txt
+%%WWWDIR%%/translations/Italian.txt
+%%WWWDIR%%/translations/Japanese-eucjp.txt
+%%WWWDIR%%/translations/Japanese-sjis.txt
+%%WWWDIR%%/translations/Japanese.txt
+%%WWWDIR%%/translations/Korean.txt
+%%WWWDIR%%/translations/Lithuanian.txt
+%%WWWDIR%%/translations/Norwegian.txt
+%%WWWDIR%%/translations/Polish.txt
+%%WWWDIR%%/translations/Portuguese.txt
+%%WWWDIR%%/translations/Portuguese_BR.txt
+%%WWWDIR%%/translations/Romanian.txt
+%%WWWDIR%%/translations/Russian.txt
+%%WWWDIR%%/translations/Russian_utf8.txt
+%%WWWDIR%%/translations/Serbian_utf8.txt
+%%WWWDIR%%/translations/Slovak_utf8.txt
+%%WWWDIR%%/translations/Slovenian.txt
+%%WWWDIR%%/translations/Spanish.txt
+%%WWWDIR%%/translations/Swedish.txt
+%%WWWDIR%%/translations/Turkish.txt
+%%WWWDIR%%/translations/Welsh.txt
+%%WWWDIR%%/upcoming.php
+%%WWWDIR%%/users.php
+%%WWWDIR%%/usersel.php
+%%WWWDIR%%/view_d.php
+%%WWWDIR%%/view_entry.php
+%%WWWDIR%%/view_l.php
+%%WWWDIR%%/view_m.php
+%%WWWDIR%%/view_r.php
+%%WWWDIR%%/view_t.php
+%%WWWDIR%%/view_v.php
+%%WWWDIR%%/view_w.php
+%%WWWDIR%%/views.php
+%%WWWDIR%%/views_edit.php
+%%WWWDIR%%/views_edit_handler.php
+%%WWWDIR%%/week.php
+%%WWWDIR%%/week_details.php
+%%WWWDIR%%/week_ssi.php
+%%WWWDIR%%/ws/activity_log.php
+%%WWWDIR%%/ws/event_mod.php
+%%WWWDIR%%/ws/get_events.php
+%%WWWDIR%%/ws/get_reminders.php
+%%WWWDIR%%/ws/get_unapproved.php
+%%WWWDIR%%/ws/get_users.php
+%%WWWDIR%%/ws/login.php
+%%WWWDIR%%/ws/user_mod.php
+%%WWWDIR%%/ws/webcalendar.jar
+%%WWWDIR%%/ws/ws.php
+%%WWWDIR%%/year.php
+@dirrm %%WWWDIR%%/ws
+@dirrm %%WWWDIR%%/translations
+@dirrm %%WWWDIR%%/tools
+@dirrm %%WWWDIR%%/themes
+@dirrm %%WWWDIR%%/tests
+@dirrm %%WWWDIR%%/install/sql
+@dirrm %%WWWDIR%%/install
+@dirrm %%WWWDIR%%/includes/menu/themes/touch_of_greydient
+@dirrm %%WWWDIR%%/includes/menu/themes/touch_of_grey
+@dirrm %%WWWDIR%%/includes/menu/themes/spring
+@dirrm %%WWWDIR%%/includes/menu/themes/office2003
+@dirrm %%WWWDIR%%/includes/menu/themes/default
+@dirrm %%WWWDIR%%/includes/menu/themes/darkness
+@dirrm %%WWWDIR%%/includes/menu/themes/autumn
+@dirrm %%WWWDIR%%/includes/menu/themes
+@dirrm %%WWWDIR%%/includes/menu/icons/mini
+@dirrm %%WWWDIR%%/includes/menu/icons
+@dirrm %%WWWDIR%%/includes/menu
+@dirrm %%WWWDIR%%/includes/js
+@dirrm %%WWWDIR%%/includes/classes/phpmailer
+@dirrm %%WWWDIR%%/includes/classes/hKit
+@dirrm %%WWWDIR%%/includes/classes/captcha
+@dirrm %%WWWDIR%%/includes/classes
+@dirrm %%WWWDIR%%/includes
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/icons
+@dirrm %%WWWDIR%%/docs
+@dirrm %%WWWDIR%%