aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/twhttpd/Makefile27
-rw-r--r--www/twhttpd/distinfo1
-rw-r--r--www/twhttpd/files/patch-aa11
-rw-r--r--www/twhttpd/files/patch-ab16
-rw-r--r--www/twhttpd/files/patch-ac11
-rw-r--r--www/twhttpd/files/patch-ad11
-rw-r--r--www/twhttpd/pkg-comment1
-rw-r--r--www/twhttpd/pkg-descr14
-rw-r--r--www/twhttpd/pkg-message5
-rw-r--r--www/twhttpd/pkg-plist3
11 files changed, 101 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3e405bd69728..454e1ce96da5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -399,6 +399,7 @@
SUBDIR += tidy
SUBDIR += tinyproxy
SUBDIR += transproxy
+ SUBDIR += twhttpd
SUBDIR += twig
SUBDIR += udmsearch
SUBDIR += ump
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
new file mode 100644
index 000000000000..bf83ff974d2b
--- /dev/null
+++ b/www/twhttpd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: twhttpd-1.0
+# Date created: 25 Sep 2002
+# Whom: Pieter Danhieux <opr@bsdaemon.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twhttpd
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.geocities.com/samngms/twhttpd/download/
+DISTNAME= twhttpd-${PORTVERSION}
+
+MAINTAINER= opr@bsdaemon.be
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOCONF= yes
+
+do-install:
+ @${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
+ @${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
+ @${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>
diff --git a/www/twhttpd/distinfo b/www/twhttpd/distinfo
new file mode 100644
index 000000000000..3acf24d49358
--- /dev/null
+++ b/www/twhttpd/distinfo
@@ -0,0 +1 @@
+MD5 (twhttpd-1.0.tar.gz) = 09b49b470e689fc1e5917b9503cea71d
diff --git a/www/twhttpd/files/patch-aa b/www/twhttpd/files/patch-aa
new file mode 100644
index 000000000000..919d055e56f1
--- /dev/null
+++ b/www/twhttpd/files/patch-aa
@@ -0,0 +1,11 @@
+--- config.h.orig Sat Aug 31 05:40:23 2002
++++ config.h Wed Sep 25 12:01:58 2002
+@@ -31,7 +31,7 @@
+ #define CURRENT_DIR "./"
+ #define DEFAULT_CACHE_DIR ".cache"
+ #define DEFAULT_COOKIE_DIR ".cookie"
+-#define DEFAULT_CONFIG_FILE "/etc/twhttpd.cfg"
++#define DEFAULT_CONFIG_FILE "/usr/local/etc/twhttpd.cfg"
+
+ #define SOCKET_TIMEOUT 45 /* socket timeout value */
+ #define CONNECT_TIMEOUT 15 /* connect timeout value */
diff --git a/www/twhttpd/files/patch-ab b/www/twhttpd/files/patch-ab
new file mode 100644
index 000000000000..21c2a4f895ab
--- /dev/null
+++ b/www/twhttpd/files/patch-ab
@@ -0,0 +1,16 @@
+--- httplog.c.orig Sat Dec 8 15:15:44 2001
++++ httplog.c Wed Sep 25 12:02:28 2002
+@@ -40,6 +40,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <syslog.h>
++#include <arpa/inet.h>
+ #include <netinet/in.h>
+ #include <sys/time.h>
+ #include <sys/socket.h>
+@@ -151,4 +152,4 @@
+ }
+ }
+ }
+-}
++}
diff --git a/www/twhttpd/files/patch-ac b/www/twhttpd/files/patch-ac
new file mode 100644
index 000000000000..a663815b5f49
--- /dev/null
+++ b/www/twhttpd/files/patch-ac
@@ -0,0 +1,11 @@
+--- twhttpd.c.orig Sat Aug 31 05:16:35 2002
++++ twhttpd.c Wed Sep 25 12:02:49 2002
+@@ -33,7 +33,7 @@
+ #include <signal.h>
+ #include <time.h>
+ #include <unistd.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
diff --git a/www/twhttpd/files/patch-ad b/www/twhttpd/files/patch-ad
new file mode 100644
index 000000000000..3d5ace1c5058
--- /dev/null
+++ b/www/twhttpd/files/patch-ad
@@ -0,0 +1,11 @@
+--- configure.in.orig Wed Sep 25 12:41:35 2002
++++ configure.in Wed Sep 25 12:41:44 2002
+@@ -8,7 +8,7 @@
+ AC_PROG_LEX
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(pwdb, crypt)
++AC_CHECK_LIB(crypt, crypt)
+ AC_CHECK_LIB(socket, bind)
+ AC_CHECK_LIB(nsl, gethostbyname)
+
diff --git a/www/twhttpd/pkg-comment b/www/twhttpd/pkg-comment
new file mode 100644
index 000000000000..635dbe9311dc
--- /dev/null
+++ b/www/twhttpd/pkg-comment
@@ -0,0 +1 @@
+Secure HTTP Proxy
diff --git a/www/twhttpd/pkg-descr b/www/twhttpd/pkg-descr
new file mode 100644
index 000000000000..3cb9f05ea657
--- /dev/null
+++ b/www/twhttpd/pkg-descr
@@ -0,0 +1,14 @@
+twhttpd is a powerful secure HTTP proxy.
+twhttpd protects your internal Web server by acting as an inbound proxy
+(like a reserve Squid proxy). It can also work as a secure outbound proxy
+to protect your browser client. It allows you to inspect almost every
+detail of the HTTP protocol headers, including the URL request line, the
+server version, user-agent, referrer, cookie, query, etc., in a
+easy-to-use script-like configuration file.
+This program is generally considered an "Expert Tool"; you will need
+knowledge of the HTTP protocol to configure the proxy properly.
+
+WWW: http://www.geocities.com/samngms/twhttpd/
+
+- Pieter
+opr@bsdaemon.be
diff --git a/www/twhttpd/pkg-message b/www/twhttpd/pkg-message
new file mode 100644
index 000000000000..92e87913862d
--- /dev/null
+++ b/www/twhttpd/pkg-message
@@ -0,0 +1,5 @@
+***************************************************************************
+twhttpd is installed in /usr/local/sbin/
+Now copy /usr/local/etc/twhttpd.cfg.sample to twhttpd.cfg,
+and edit it.
+***************************************************************************
diff --git a/www/twhttpd/pkg-plist b/www/twhttpd/pkg-plist
new file mode 100644
index 000000000000..e0c8911ac315
--- /dev/null
+++ b/www/twhttpd/pkg-plist
@@ -0,0 +1,3 @@
+sbin/twhttpd
+sbin/rm_cache
+etc/twhttpd.cfg.sample
s new dictionaries.thierry2004-08-293-0/+22 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-243-20/+10 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * SIZEify (maintainer timeout)trevor2004-03-3113-0/+14 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-102-2/+1 * - rpm2cpio.pl need to be EXTRACT_DEPENDS otherwise it will not workpav2004-03-021-1/+1 * Update to KDE 3.2.0lofi2004-02-053-5/+6 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-2/+2 * Now gettext 0.12.1 is gettext-old.trevor2004-01-241-1/+1 * Use the CPIO macro defined in bsd.port.mk.trevor2004-01-221-1/+1 * Use the SORT macro from bsd.port.mk.trevor2004-01-221-1/+1 * s/rpm2cpio/rpm2cpio.pl/ after the recent update of archivers/rpm2cpio (thenetchild2003-12-121-2/+2 * Another last minute change. Size/date stamp changes only.will2003-09-281-1/+1 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-181-2/+1 * Update this port from being based on the X11 R6.5.1 sources to R6.6.obrien2003-08-182-3/+4 * Remove the _POSIX_SOURCE handling to fix the building on 5-CURRENT.obrien2003-08-182-6/+2 * Update KDE to the latest official release, KDE 3.1.3lofi2003-07-292-1/+63 * Fix PLISTlioux2003-06-131-1/+17 * Update to KDE 3.1.2lioux2003-05-201-1/+1 * Add a NO_VIET_KDE knob to avoid the KDE I18N bits -- otherwise it is hard toobrien2003-05-091-0/+2 * BROKEN: Does not compilekris2003-05-071-0/+2 * Repo-move KDE I18N hebrew, hungarian, & vietnamese messages to theirwill2003-04-144-5/+72 * Clear moonlight beckons.ade2003-03-0730-15/+15 * Upgrade kde-i18n to 3.1. Note that the following modules did not get awill2003-01-292-38/+34 * Perl script to convert the text in the VIQR encoding to another Vietnameseobrien2002-11-136-0/+68 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-1126-26/+13 * Use PORTCOMMENT.obrien2002-11-0726-13/+26 * Add a missing directorykris2002-10-281-0/+1 * Get the dependencies correct for XF4.obrien2002-10-171-1/+1 * revert last commit. This builds fine here, and I've never seen oneobrien2002-10-171-2/+0 * Unmark broken. Please have the decentcy to notify the maintainer of a buildobrien2002-10-171-2/+0 * 1. Removed comments from pkg-plist files per will's request.alane2002-10-112-3/+27 * BROKEN: Does not compilekris2002-10-061-0/+2 * BROKEN: Missing dependencieskris2002-10-061-0/+2 * Don't gratuitously add -O.obrien2002-09-091-2/+2 * 'union wait' was depreciated by the time of Net/2.obrien2002-09-091-13/+24 * Catch up with lossage of 'union wait' in 5-CURRENT.obrien2002-09-092-21/+34 * Fix corrupted comment line.obrien2002-09-091-1/+1 * I have no idea what bsd.port.mk change broke this port, but be moreobrien2002-09-091-0/+1 * Update to 3.0.3. Not much changed here: [1] i18n PKGNAMEs converted towill2002-08-253-4/+4 * 1. Changed the lib depends on gettext to a build depends. This will meanalane2002-08-031-2/+2 * Bump PORTREVISION. KDE is fragile enough in its dependencies; we don'talane2002-08-021-0/+1 * Chase shlib rev of devel/gettextade2002-08-021-1/+1 * Fix MASTER_SITE_SUBDIR.will2002-07-101-1/+1 * Update to 3.0.2 -- full log available in ports/x11/kde3/Makefile,v 1.51.will2002-07-053-5/+12 * Upgrade to KDE 3.0.1. The delay in this upgrade is mainly due to thewill2002-06-163-2/+32 * Please welcome Qt3/KDE3 to our ports tree. This includes work since thewill2002-04-227-128/+154 * gettext upgrade uber-patch (stage 3)ade2002-04-131-1/+2 * Stage 1 of gettext update.ade2002-03-161-1/+1 * Add WWW.demon2001-12-281-0/+2 * Update to 2.2.2.demon2001-12-133-9/+16 * Note the standard these utilities conform to.obrien2001-11-2815-35/+133 * Unicode TrueType Font with UHoai Vietnamese encodingobrien2001-11-288-0/+60 * VISCII->Unicode conversionobrien2001-11-286-0/+36 * Upgrade to 2.2.1.demon2001-10-276-26/+23 * Sort entries.knu2001-09-211-3/+2 * Set DIST_SUBDIR=KDEdemon2001-09-112-1/+2 * MAINTAINER -> kde@FreeBSD.orgdemon2001-09-011-1/+1 * Our -man package does not understand .PN and .MS. So use .B (bold) untilobrien2001-08-232-18/+158 * Fix installation in a slightly different way.demon2001-08-212-6/+8 * Remove two languages not presented in new version.demon2001-08-201-3/+1 * Forgot to remove debug comment.demon2001-08-161-1/+1 * Upgrade to 2.2.demon2001-08-165-8/+31 * Note that VNterm adheres to RFC 1456 (VISCII and VIQR encodings)obrien2001-07-151-0/+6 * Remove Ukrainian from BATCH builds.demon2001-07-051-1/+1 * Exclude de, fr, ja, ru, zh_CN, zh_TW from bento's package.demon2001-04-171-1/+1 * Use `cp' rather than `ln' as WRKDIR and FILESDIR can be on different devices.obrien2001-04-171-1/+1 * Sort languages by name.demon2001-04-131-10/+10 * Examine LINGUAS variable before BATCH.demon2001-04-111-5/+5 * Allow to override MAINTAINER and CATEGORIES (in slave ports).demon2001-04-101-2/+2 * Add the ability to select which languages to install via dialog(1)-baseddemon2001-04-102-0/+87 * Update to 2.1.1demon2001-04-063-13/+2 * Change dot file to .vnelvisrc from .exrc.obrien2001-04-051-8/+26 * Default to Vietnamese processing.obrien2001-04-051-0/+5 * Overhaul QT/KDE support:will2001-04-031-2/+2 * Install new manpage.obrien2001-03-261-0/+2 * Add FreeBSD ID.obrien2001-03-261-0/+1 * Grr. a local cc(1) option got added by mistake.obrien2001-03-261-3/+3 * Sigh. This code is based on vnlibs. Thus I need to fix the Pascal'ismobrien2001-03-261-0/+8 * Respect CFLAGS.obrien2001-03-261-0/+11 * Add a man page.obrien2001-03-261-0/+65 * Minor tweak.obrien2001-03-261-2/+2 * Add reference to vnconvert(1).obrien2001-03-263-0/+3 * unbreak post-install script.sf2001-03-191-1/+1 * Use full path to `mkfontdir'.obrien2001-03-131-1/+1 * Make sure teTeX is installed before installing this port.obrien2001-03-131-0/+3 * Update to the 20010210 version. This fixes occasional core dumps in apps.obrien2001-03-092-2/+2 * New port: localized messages and documentation for KDE2.demon2001-03-025-0/+38 * Add aliases.obrien2001-02-163-0/+15 * Make this build when it is in the full /usr/ports tree and "vi-" is prependedobrien2001-02-121-1/+1 * Use the new libviet port in building.obrien2001-02-123-16/+15 * Use the new libviet port in building.obrien2001-02-113-14/+17 * Update vnterm so it is based on the X11R6.5.1 Xterm rather than the X11R5 one.obrien2001-02-1123-191/+1411 * Fix prefix bogon.obrien2001-02-111-0/+1 * These X fonts allow you to display Vietnamese characters in an Xterm andobrien2001-02-118-0/+134 * VIQR<->VISCII conversion and VISCII ctype-like routinesobrien2001-02-106-0/+49 * teTeX Vietnamese language + font supportobrien2001-02-078-0/+475 * Style fixes in ports/vietnamese.olgeni2001-02-061-1/+1 * Converts Vietnamese text files between popular formats.obrien2001-01-066-0/+40 * Add $FreeBSD$, which help me in problem reports.obrien2000-11-221-0/+1 * Fix curses clear() usage.obrien2000-11-033-0/+54 * Change PKGDIR from pkg/ to . Also fix places where ${PKGDIR} isasami2000-10-081-1/+1 * Add dependency to mkfontdir:XFree86-4-clients when XFREE86_VERSION=4.asami2000-09-121-1/+8 * Back out the previous commit. That one has a problem which occurs onknu2000-08-281-5/+1 * PKGNAMEPREFIX cleanup. This should allow chained PKGNAMEPREFIX'es.knu2000-08-271-1/+5 * Add one manpage, one doc file and delete two directories.asami2000-07-052-0/+4 * List two files in share/doc/vnlpr and delete the directory upon deinstall.asami2000-07-051-2/+3 * Update the manpage to note this now adhears to Vietnamese Standard Code forobrien2000-05-214-7/+58 * Correct whitespace introduced during PORTNAME conversion and portlintmharo2000-04-216-6/+6 * Remove "vi-" prefix from PORTNAMEs, they are set by PKGNAMEPREFIX inasami2000-04-157-12/+12 * Set PKGNAMEPREFIX with ?= so it can be overridden.asami2000-04-111-1/+1 * Add PKGNAMEPREFIX definitions for language-specific dirs.asami2000-04-111-0/+4 * Update with the new PORTNAME/PORTVERSION variablescpiazza2000-04-107-21/+20 * Restore useless version required comments.obrien2000-03-227-0/+7 * Remove the "version required" line.obrien2000-03-207-7/+0 * Style nits in the ports I maintain.obrien2000-02-137-13/+13 * adjust for my editorobrien1999-09-065-0/+5 * $Id$ -> $FreeBSD$peter1999-08-3117-17/+17 * ln -> ${LN}mharo1999-08-281-3/+3 * chmod -> ${CHMOD}mharo1999-08-232-6/+6 * Make this port reinstall friendly.steve1999-07-051-8/+3 * #4/4 enforcing Caps, no periodhoek1999-06-275-5/+5 * mark unbroken - can't repeat the problemobrien1998-11-071-3/+1 * mark unbroken -- I can't duplicate the problem on 3 different machinesobrien1998-11-071-3/+1 * make buildable on ELFobrien1998-11-071-3/+5 * mark unbroken -- I can't repeat the problem on 3 different machinesobrien1998-11-071-3/+1 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Mark BROKEN for ELF:jseger1998-10-161-1/+3 * Mark BROKEN for ELF:jseger1998-10-161-1/+3