aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-Application-Server/Makefile8
-rw-r--r--www/p5-CGI.pm/Makefile8
-rw-r--r--www/p5-Furl/Makefile8
-rw-r--r--www/p5-HTML-Shakan/Makefile8
-rw-r--r--www/p5-HTTP-BrowserDetect/Makefile8
-rw-r--r--www/p5-HTTP-MobileAgent-Plugin-Charset/Makefile8
-rw-r--r--www/p5-POE-Component-Client-HTTP/Makefile8
-rw-r--r--www/p5-STF-Dispatcher-PSGI/Makefile8
-rw-r--r--www/p5-WWW-GitHub-Gist/Makefile9
-rw-r--r--www/p5-WWW-TinySong/Makefile8
-rw-r--r--www/p5-Web-Query/Makefile8
11 files changed, 11 insertions, 78 deletions
diff --git a/www/p5-CGI-Application-Server/Makefile b/www/p5-CGI-Application-Server/Makefile
index 11b8d0991a19..54c3c90ede4f 100644
--- a/www/p5-CGI-Application-Server/Makefile
+++ b/www/p5-CGI-Application-Server/Makefile
@@ -29,10 +29,4 @@ TEST_DEPENDS= p5-CGI-Application>0:${PORTSDIR}/www/p5-CGI-Application \
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index 12419fda3d98..bb844677f725 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -35,10 +35,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Furl/Makefile b/www/p5-Furl/Makefile
index 2ee4e9f0d03b..5ff60e9df8f2 100644
--- a/www/p5-Furl/Makefile
+++ b/www/p5-Furl/Makefile
@@ -27,10 +27,4 @@ TEST_DEPENDS= p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires \
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Shakan/Makefile b/www/p5-HTML-Shakan/Makefile
index 0bdb99143a53..90e4b84edc64 100644
--- a/www/p5-HTML-Shakan/Makefile
+++ b/www/p5-HTML-Shakan/Makefile
@@ -30,10 +30,4 @@ TEST_DEPENDS= \
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-BrowserDetect/Makefile b/www/p5-HTTP-BrowserDetect/Makefile
index 5e61602b9aab..a32e441f9977 100644
--- a/www/p5-HTTP-BrowserDetect/Makefile
+++ b/www/p5-HTTP-BrowserDetect/Makefile
@@ -22,10 +22,4 @@ TEST_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-JSON-PP>=0:${PORTSDIR}/converters/p5-JSON-PP
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-MobileAgent-Plugin-Charset/Makefile b/www/p5-HTTP-MobileAgent-Plugin-Charset/Makefile
index b07140bedc27..98aab425feab 100644
--- a/www/p5-HTTP-MobileAgent-Plugin-Charset/Makefile
+++ b/www/p5-HTTP-MobileAgent-Plugin-Charset/Makefile
@@ -16,10 +16,4 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-POE-Component-Client-HTTP/Makefile b/www/p5-POE-Component-Client-HTTP/Makefile
index 6c2ffb1f1ec4..d50435924f7d 100644
--- a/www/p5-POE-Component-Client-HTTP/Makefile
+++ b/www/p5-POE-Component-Client-HTTP/Makefile
@@ -26,10 +26,4 @@ TEST_DEPENDS= p5-Test-POE-Server-TCP>=1.14:${PORTSDIR}/devel/p5-Test-POE-Server-
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-STF-Dispatcher-PSGI/Makefile b/www/p5-STF-Dispatcher-PSGI/Makefile
index 36687fc3bd02..a440157a296e 100644
--- a/www/p5-STF-Dispatcher-PSGI/Makefile
+++ b/www/p5-STF-Dispatcher-PSGI/Makefile
@@ -23,10 +23,4 @@ TEST_DEPENDS= \
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-GitHub-Gist/Makefile b/www/p5-WWW-GitHub-Gist/Makefile
index 61f4281a1956..7e2034cb22ef 100644
--- a/www/p5-WWW-GitHub-Gist/Makefile
+++ b/www/p5-WWW-GitHub-Gist/Makefile
@@ -20,11 +20,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-BUILD_DEPENDS+= p5-HTTP-Tiny>=0:${PORTSDIR}/www/p5-HTTP-Tiny
-RUN_DEPENDS+= p5-HTTP-Tiny>=0:${PORTSDIR}/www/p5-HTTP-Tiny
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-TinySong/Makefile b/www/p5-WWW-TinySong/Makefile
index 55f93c1f6bc9..058c139587ce 100644
--- a/www/p5-WWW-TinySong/Makefile
+++ b/www/p5-WWW-TinySong/Makefile
@@ -18,10 +18,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Web-Query/Makefile b/www/p5-Web-Query/Makefile
index 6e0830fd342d..353d0d24a413 100644
--- a/www/p5-Web-Query/Makefile
+++ b/www/p5-Web-Query/Makefile
@@ -19,10 +19,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>