aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile9
-rw-r--r--www/apache22/distinfo4
-rw-r--r--www/apache22/files/apache22.in9
3 files changed, 18 insertions, 4 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index bf8fdce8c805..79fafe0a1591 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= apache22
-PORTVERSION= 2.2.26
+PORTVERSION= 2.2.27
#PORTREVISION?= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
@@ -63,6 +63,13 @@ SUEXEC_USERDIR_EXTRA_PATCHES= ${FILESDIR}/extra-patch-suexec_userdir
ETC_SUBDIRS= Includes envvars.d extra modules.d
+# PR: 182947
+.if ${WITH_MPM} != "peruser"
+SUB_LIST+= RELOAD_CMD=graceful
+.else
+SUB_LIST+= RELOAD_CMD=hrestart
+.endif
+
.if ! ${PORT_OPTIONS:MDOCS}
MAKE_ENV+= NOPORTDOCS=yes
.endif
diff --git a/www/apache22/distinfo b/www/apache22/distinfo
index 1a1fb6e2a5a7..48a2d66a83c6 100644
--- a/www/apache22/distinfo
+++ b/www/apache22/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apache22/httpd-2.2.26.tar.bz2) = af908e3dd5673f1c6f0ccc615e11d435e77517940af00e518e68ea25284b42b6
-SIZE (apache22/httpd-2.2.26.tar.bz2) = 5390190
+SHA256 (apache22/httpd-2.2.27.tar.bz2) = 205973ded6ca55c056ce9c84d73ab708f7829f330193bd39b651463b8d4f8147
+SIZE (apache22/httpd-2.2.27.tar.bz2) = 5616798
diff --git a/www/apache22/files/apache22.in b/www/apache22/files/apache22.in
index eab30e2a7ac0..7abcf9339eca 100644
--- a/www/apache22/files/apache22.in
+++ b/www/apache22/files/apache22.in
@@ -33,7 +33,7 @@ rcvar=apache22_enable
start_precmd="apache22_prestart"
restart_precmd="apache22_checkconfig"
reload_precmd="apache22_checkconfig"
-reload_cmd="apache22_graceful"
+reload_cmd="apache22_%%RELOAD_CMD%%"
graceful_cmd="apache22_graceful"
gracefulstop_cmd="apache22_gracefulstop"
configtest_cmd="apache22_checkconfig"
@@ -152,6 +152,13 @@ apache22_graceful() {
eval ${command} ${apache22_flags} -k graceful
}
+apache22_hrestart() {
+ apache22_requirepidfile
+
+ echo "Performing a graceful restart"
+ eval ${command} ${apache22_flags} -k restart
+}
+
apache22_gracefulstop() {
apache22_requirepidfile