aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile4
-rw-r--r--www/apache22/Makefile3
-rw-r--r--www/asterisk-gui/Makefile4
-rw-r--r--www/asterisk-gui/files/patch-bootstrap.sh2
-rw-r--r--www/bookmarkbridge/Makefile4
-rw-r--r--www/fcgiwrap/Makefile4
-rw-r--r--www/flood/Makefile4
-rw-r--r--www/gforge/Makefile3
-rw-r--r--www/kdewebdev/Makefile4
-rw-r--r--www/libapreq2/Makefile4
-rw-r--r--www/lighttpd/Makefile4
-rw-r--r--www/links/Makefile4
-rw-r--r--www/mod_cplusplus/Makefile3
-rw-r--r--www/mod_rivet/Makefile3
-rw-r--r--www/moonshine/Makefile4
-rw-r--r--www/oops/Makefile4
-rw-r--r--www/privoxy/Makefile4
-rw-r--r--www/rt38/Makefile3
-rw-r--r--www/rt40/Makefile3
-rw-r--r--www/suphp/Makefile7
-rw-r--r--www/tidy-devel/Makefile3
-rw-r--r--www/trafficserver/Makefile4
-rw-r--r--www/websh/Makefile3
23 files changed, 47 insertions, 38 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 76a6eec7db95..d9a990323b70 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.63
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/$/:powerlogo/}
@@ -52,7 +52,7 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
# THREADS "Enable threads in apr" Off
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
USE_PERL5= yes
USE_RC_SUBR= apache2
USE_APACHE= common20
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 478daa564033..066d1dc524db 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,6 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.16
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -36,7 +37,7 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
USE_APACHE= common22
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
USE_PERL5= yes
USE_RC_SUBR= apache22 htcacheclean
LIBTOOLFILES= configure
diff --git a/www/asterisk-gui/Makefile b/www/asterisk-gui/Makefile
index 25b6a1e3169c..29b35bbf384e 100644
--- a/www/asterisk-gui/Makefile
+++ b/www/asterisk-gui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asterisk-gui
PORTVERSION= 2.0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk-gui/releases/
@@ -18,7 +18,7 @@ RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk \
wget:${PORTSDIR}/ftp/wget
PROJECTHOST= asterisk-bsd
-USE_AUTOTOOLS= autoconf:262 automake:19
+USE_AUTOTOOLS= autoconf:267 automake:19
USE_GMAKE= yes
SUB_FILES= pkg-message
diff --git a/www/asterisk-gui/files/patch-bootstrap.sh b/www/asterisk-gui/files/patch-bootstrap.sh
index 554cf1620080..55d76d3563ff 100644
--- a/www/asterisk-gui/files/patch-bootstrap.sh
+++ b/www/asterisk-gui/files/patch-bootstrap.sh
@@ -6,7 +6,7 @@
if [ $? = 0 ] ; then # FreeBSD case
- MY_AC_VER=259
- MY_AM_VER=19
-+ MY_AC_VER=-2.62
++ MY_AC_VER=-2.67
+ MY_AM_VER=-1.9
else # linux case
MY_AC_VER=
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index a51807091b88..c15f44138b02 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bookmarkbridge
PORTVERSION= 0.76
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= SF
@@ -22,7 +22,7 @@ USE_QT_VER= 4
QT_COMPONENTS= corelib gui moc_build rcc_build uic_build qt3support
USE_GNOME= gnometarget libxml2
USE_GMAKE= yes
-USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:262
+USE_AUTOTOOLS= aclocal:19 automake:19 autoconf:267
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
.include <bsd.port.pre.mk>
diff --git a/www/fcgiwrap/Makefile b/www/fcgiwrap/Makefile
index d934fd6585e0..8721621c9414 100644
--- a/www/fcgiwrap/Makefile
+++ b/www/fcgiwrap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fcgiwrap
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://cloud.github.com/downloads/gnosek/fcgiwrap/
@@ -21,7 +21,7 @@ LICENSE= MIT
USE_RC_SUBR= fcgiwrap
-USE_AUTOTOOLS= autoconf:262:env autoheader:262
+USE_AUTOTOOLS= autoconf:267:env autoheader:267
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 1b00a6afcdf2..582ffc78fb73 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flood
PORTVERSION= 0.20041105
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://dist.bsdlab.org/
DISTNAME= httpd-test_20041105052051
@@ -19,7 +19,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
apr-1:${PORTSDIR}/devel/apr1
WRKSRC= ${WRKDIR}/httpd-test/flood
-USE_AUTOTOOLS= autoconf:262 libtool:22:env
+USE_AUTOTOOLS= autoconf:267 libtool:22:env
CONFIGURE_ARGS= --disable-shared \
--with-apr=${LOCALBASE}/bin/apr-1-config \
--with-apr-util=${LOCALBASE}/bin/apu-1-config
diff --git a/www/gforge/Makefile b/www/gforge/Makefile
index 596a9680e459..772adae7ba57 100644
--- a/www/gforge/Makefile
+++ b/www/gforge/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gforge
PORTVERSION= 4.5.19
+PORTREVISION= 1
CATEGORIES= www devel
MASTER_SITES= http://gforge.org/gf/download/frsrelease/150/245/
@@ -19,7 +20,7 @@ USE_BZIP2= YES
USE_PERL5= YES
HAS_CONFIGURE= YES
USE_APACHE= 13
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
NO_BUILD= YES
USE_PHP= pgsql session pcre
WANT_PHP_CLI= YES
diff --git a/www/kdewebdev/Makefile b/www/kdewebdev/Makefile
index d07bad69c9c6..46ec19428ce3 100644
--- a/www/kdewebdev/Makefile
+++ b/www/kdewebdev/Makefile
@@ -17,8 +17,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Comprehensive html/website development environment
-BUILD_DEPENDS= cvsservice:${PORTSDIR}/devel/kdesdk3 \
- xgettext:${PORTSDIR}/devel/gettext
+BUILD_DEPENDS= cvsservice:${PORTSDIR}/devel/kdesdk3
RUN_DEPENDS= cvsservice:${PORTSDIR}/devel/kdesdk3 \
tidy:${PORTSDIR}/www/tidy-lib
@@ -28,6 +27,7 @@ PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_XORG= xpm
USE_GMAKE= yes
+USE_GETTEXT= build
USE_AUTOTOOLS= libtool:22
.include <${.CURDIR}/../../x11/kde3/Makefile.kde>
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index d20273670f7b..a236ef64d068 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libapreq2
PORTVERSION= 2.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
@@ -18,7 +18,7 @@ COMMENT= Generic Apache2 Request Library
USE_APACHE= 2.0+
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
MAKE_ENV+= MAKE=${GMAKE} ## MakeMaker blows it without this
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 6999872abe80..aae10fdfe42b 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.28
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
@@ -20,7 +20,7 @@ LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= lthack
-USE_AUTOTOOLS= autoconf:262 autoheader:262 aclocal:110 automake:110 libtool:22
+USE_AUTOTOOLS= autoconf:267 autoheader:267 aclocal:110 automake:110 libtool:22
ACLOCAL_ARGS= -I m4
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd --enable-static
diff --git a/www/links/Makefile b/www/links/Makefile
index 3ddd89e011c9..2aacc87fb0e9 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -7,7 +7,7 @@
PORTNAME= links
DISTVERSION= 2.2
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES= http://links.twibright.com/download/
@@ -64,7 +64,7 @@ CONFIGURE_ARGS+= --without-directfb
.endif
.if defined(WITH_IPV6)
-USE_AUTOTOOLS+= autoconf:262
+USE_AUTOTOOLS+= autoconf:267
PATCH_SITES+= http://xpisar.wz.cz/links-ipv6/:ipv6
PATCHFILES+= links-2.2-ipv6-2.diff:ipv6
.endif
diff --git a/www/mod_cplusplus/Makefile b/www/mod_cplusplus/Makefile
index b38cc1b1ab03..d02d3510d10a 100644
--- a/www/mod_cplusplus/Makefile
+++ b/www/mod_cplusplus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_cplusplus
PORTVERSION= 1.5.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF/modcplusplus/modcplusplus/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -17,7 +18,7 @@ COMMENT= Apache module for loading C++ objects as handlers
MAKE_JOBS_SAFE= yes
USE_APACHE= 2.0+
-USE_AUTOTOOLS= autoconf:262 autoheader:262 libtool:22 automake:19 aclocal:19
+USE_AUTOTOOLS= autoconf:267 autoheader:267 libtool:22 automake:19 aclocal:19
CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
diff --git a/www/mod_rivet/Makefile b/www/mod_rivet/Makefile
index 5e02eeeb2168..fc1a745220e5 100644
--- a/www/mod_rivet/Makefile
+++ b/www/mod_rivet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_rivet
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= www tcl
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tcl/rivet
@@ -20,7 +21,7 @@ WRKSRC= ${WRKDIR}/rivet-${PORTVERSION}
MAKE_JOBS_SAFE= yes
USE_APACHE= 2.0+
-USE_AUTOTOOLS= automake:110 autoconf:262
+USE_AUTOTOOLS= automake:110 autoconf:267
USE_TCL= 84+
GMAKE= yes
diff --git a/www/moonshine/Makefile b/www/moonshine/Makefile
index 96d174e64a9c..5494e711932f 100644
--- a/www/moonshine/Makefile
+++ b/www/moonshine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moonshine
PORTVERSION= 0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www multimedia
MASTER_SITES= http://romain.blogreen.org/distfiles/
DISTNAME= abock-${PORTNAME}-${GITCOMMIT}
@@ -20,7 +20,7 @@ GITCOMMIT= 35085a4
USE_GMAKE= yes
USE_GECKO= libxul
-USE_AUTOTOOLS= libtool:22 libtoolize aclocal:110 autoconf:262 autoheader:262 automake:110
+USE_AUTOTOOLS= libtool:22 libtoolize aclocal:110 autoconf:267 autoheader:267 automake:110
LIBTOOLIZE_ARGS= --force --copy --automake
AUTOMAKE_ARGS= --gnu --add-missing --force --copy -Wno-portability
ACLOCAL_ARGS=
diff --git a/www/oops/Makefile b/www/oops/Makefile
index 09b5d9cc7129..07cc46c9e30f 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oops
PORTVERSION= ${OOPSVERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www
MASTER_SITES= http://oops-cache.org/ \
ftp://kucha.ru/pub/misc/oops/
@@ -21,7 +21,7 @@ BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
OOPSVERSION= 1.5.24
USE_SUBMAKE= yes
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
CONFIGURE_ARGS?=--sbindir=${PREFIX}/sbin \
--sysconfdir=${PREFIX}/etc/oops \
--localstatedir=${OOPSVAR} \
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 9ff829926c41..151a4a2b008b 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= privoxy
PORTVERSION= 3.0.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= SF/ijbswa/Sources/${PORTVERSION}%20%28stable%29
DISTNAME= privoxy-${PORTVERSION}-stable-src
@@ -20,7 +20,7 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
USE_RC_SUBR= privoxy
SUB_FILES= pkg-message
diff --git a/www/rt38/Makefile b/www/rt38/Makefile
index bf2974ea4425..1e9563a2ed57 100644
--- a/www/rt38/Makefile
+++ b/www/rt38/Makefile
@@ -13,6 +13,7 @@
PORTNAME= rt
PORTVERSION= 3.8.8
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/
@@ -53,7 +54,7 @@ BUILD_DEPENDS+= ${CORE_DEPS} \
RUN_DEPENDS+= ${BUILD_DEPENDS}
USE_PERL5= 5.8.3+
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
.include <bsd.port.pre.mk>
.if defined(WITH_DEV)
diff --git a/www/rt40/Makefile b/www/rt40/Makefile
index bf2974ea4425..1e9563a2ed57 100644
--- a/www/rt40/Makefile
+++ b/www/rt40/Makefile
@@ -13,6 +13,7 @@
PORTNAME= rt
PORTVERSION= 3.8.8
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/
@@ -53,7 +54,7 @@ BUILD_DEPENDS+= ${CORE_DEPS} \
RUN_DEPENDS+= ${BUILD_DEPENDS}
USE_PERL5= 5.8.3+
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
.include <bsd.port.pre.mk>
.if defined(WITH_DEV)
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index 8d44936c9d8b..de3dc96912e3 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= suphp
PORTVERSION= 0.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.suphp.org/download/ \
${MASTER_SITE_LOCAL:S|%SUBDIR%|koitsu|}
@@ -16,7 +16,7 @@ MAINTAINER= yzlin@FreeBSD.org
COMMENT= Securely execute PHP scripts under Apache
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal:110:env automake:110:env autoconf:262:env libtool:22:env
+USE_AUTOTOOLS= aclocal:110:env automake:110:env autoconf:267:env libtool:22:env
# Maintainer has not tested suPHP 0.6.x on Apache 1.3.
USE_APACHE= 2.0+
@@ -40,7 +40,8 @@ CONFIGURE_ARGS+= --with-setid-mode=${WITH_SETID_MODE}
CONFIGURE_ARGS+= --with-apr=${LOCALBASE}
post-patch:
- @${REINPLACE_CMD} -e 's|2.61|2.62|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|2.61|2.67|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|1.10.1|1.10.3|g' ${WRKSRC}/aclocal.m4
@${CHMOD} 755 ${WRKSRC}/config/install-sh
post-install:
diff --git a/www/tidy-devel/Makefile b/www/tidy-devel/Makefile
index d4fe6bb2b56d..c0fc7235d221 100644
--- a/www/tidy-devel/Makefile
+++ b/www/tidy-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= tidy
DISTVERSION= 090315-cvs
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
#MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
@@ -31,7 +32,7 @@ USE_GMAKE= yes
PLIST_SUB= SHLIB="@comment " NSHLIB=""
CONFLICTS= tidy-20000804* tidy-lib-[0-9]*
.else
-USE_AUTOTOOLS= automake:15 autoconf:262 libtool:22
+USE_AUTOTOOLS= automake:15 autoconf:267 libtool:22
AUTOMAKE_ARGS+= -a -c --foreign
USE_LDCONFIG= yes
PLIST_SUB= SHLIB="" NSHLIB="@comment "
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index c2db8b9e5233..3693916c1b78 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trafficserver
PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= trafficserver
@@ -21,7 +21,7 @@ BUILD_DEPENDS= expat>0:${PORTSDIR}/textproc/expat2 \
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
+USE_AUTOTOOLS= autoconf:267 automake:110 libtool:22
USE_BZIP2= yes
USE_ICONV= yes
USE_OPENSSL= yes
diff --git a/www/websh/Makefile b/www/websh/Makefile
index e076868d22a1..e0dad85be6c7 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= websh
PORTVERSION= 3.6.0b5
+PORTREVISION= 1
CATEGORIES= www tcl
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR=tcl/${PORTNAME}/source
@@ -20,7 +21,7 @@ MAKE_JOBS_UNSAFE= yes
TCL_DVER= ${TCL_VER:S/.//}
USE_TCL= 84+
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/unix
CONFIGURE_ARGS+=--with-tclinclude=${TCL_INCLUDEDIR} \
--with-tcl=${TCL_LIBDIR}