aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI.pm/Makefile2
-rw-r--r--www/p5-CGI/Makefile30
-rw-r--r--www/p5-CGI/distinfo2
-rw-r--r--www/p5-CGI/pkg-descr15
-rw-r--r--www/p5-CGI/pkg-plist14
6 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6d3826e211fe..04cacf43cfa5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -605,6 +605,7 @@
SUBDIR += p5-Blog-Spam
SUBDIR += p5-Browser-Open
SUBDIR += p5-Business-PayPal
+ SUBDIR += p5-CGI
SUBDIR += p5-CGI-Ajax
SUBDIR += p5-CGI-Application
SUBDIR += p5-CGI-Application-Dispatch
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index e8f6677f4685..7fa29843b3a6 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -15,6 +15,8 @@ COMMENT= Simple Common Gateway Interface Class for Perl
LICENSE= ART20 GPLv1
LICENSE_COMB= dual
+CONFLICTS= p5-CGI-[4-9]*
+
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-CGI/Makefile b/www/p5-CGI/Makefile
new file mode 100644
index 000000000000..79309bedcf15
--- /dev/null
+++ b/www/p5-CGI/Makefile
@@ -0,0 +1,30 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= CGI
+PORTVERSION= 4.13
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:LEEJO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Handle Common Gateway Interface requests and responses
+
+LICENSE= ART20 GPLv1
+LICENSE_COMB= dual
+
+CONFLICTS= p5-CGI.pm-[1-3]*
+
+USES= perl5
+USE_PERL5= configure
+
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI/distinfo b/www/p5-CGI/distinfo
new file mode 100644
index 000000000000..835a7e28a9ec
--- /dev/null
+++ b/www/p5-CGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CGI-4.13.tar.gz) = 76596c8b51e75c4d9434ae8add5a4a151d5b28d1e055a257d6f5c40360966be6
+SIZE (CGI-4.13.tar.gz) = 186050
diff --git a/www/p5-CGI/pkg-descr b/www/p5-CGI/pkg-descr
new file mode 100644
index 000000000000..5996239e2aa4
--- /dev/null
+++ b/www/p5-CGI/pkg-descr
@@ -0,0 +1,15 @@
+This is the continuance of the classic perl CGI module, bundled with Perl until
+Perl 5.22. Development is continuing on p5-CGI and components of it are
+actively splitting to other modules.
+
+The older, everything-in-one-package module is still available in www/p5-CGI.pm.
+
+See also: https://metacpan.org/pod/CGI::Alternatives
+
+CGI.pm is a stable, complete and mature solution for processing and preparing
+HTTP requests and responses. Major features including processing form
+submissions, file uploads, reading and writing cookies, query string generation
+and manipulation, and processing and preparing HTTP headers. Some HTML
+generation utilities are included as well.
+
+WWW: https://metacpan.org/pod/CGI
diff --git a/www/p5-CGI/pkg-plist b/www/p5-CGI/pkg-plist
new file mode 100644
index 000000000000..38ca76639303
--- /dev/null
+++ b/www/p5-CGI/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/CGI.pm
+%%SITE_PERL%%/CGI/Carp.pm
+%%SITE_PERL%%/CGI/Cookie.pm
+%%SITE_PERL%%/CGI/File/Temp.pm
+%%SITE_PERL%%/CGI/Pretty.pm
+%%SITE_PERL%%/CGI/Push.pm
+%%SITE_PERL%%/CGI/Util.pm
+%%SITE_PERL%%/Fh.pm
+%%PERL5_MAN3%%/CGI.3.gz
+%%PERL5_MAN3%%/CGI::Carp.3.gz
+%%PERL5_MAN3%%/CGI::Cookie.3.gz
+%%PERL5_MAN3%%/CGI::Pretty.3.gz
+%%PERL5_MAN3%%/CGI::Push.3.gz
+%%PERL5_MAN3%%/CGI::Util.3.gz
d_yarn/devel/electron6/files/ini-1.3.8&id=659ae5f671621168b5422da58b6dcb246f510611'>- Update poppler to 0.22.2.mezz2013-03-211-0/+1 * Merge from area51 repository:makc2013-02-054-52/+38 * Bump PORTREVISION after KDE SC update.makc2013-02-041-1/+1 * Chase boost updatebapt2013-01-311-2/+2 * - Chase lib version changes from ilmbase and OpenEXR updatesswills2013-01-171-1/+2 * - Add upstream patch to fix build with lcms 2.4jhale2012-11-091-0/+19 * - Update Calligra Suite to 2.5.2.avilla2012-09-172-2/+20 * - Update Calligra to 2.5.1.avilla2012-09-013-7/+3 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,avilla2012-08-266-763/+295 * Update graphics/exiv2 to version 0.23.bsam2012-07-311-1/+2 * - Update Calligra to 2.4.3.avilla2012-07-052-3/+2 * - Switch dependency from postgresql-libpqxx30 to postgresql-libpqxx3.avilla2012-07-031-3/+3 * - Detect eigen2 by checking for .pc file, not min. port version.avilla2012-06-271-2/+2 * - update png to 1.5.10dinoex2012-06-011-1/+2 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-3110-3067/+6235 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-161-1/+1 * Update poppler to 0.18.0.kwm2011-10-311-1/+1 * - update fftw3* to 3.3 [1], and adjust dependent portsbf2011-10-171-2/+2 * - Update dependencies after KDE ports upgrade.avilla2011-10-171-3/+4 * - Revert 1.148.avilla2011-10-171-2/+1 * Remove optional dependencies on databases/xbase, which is about to be removeddougb2011-10-092-12/+0 * - Fix PKGNAME and UNIQUENAME.avilla2011-10-071-1/+2 * Chase poppler shlib bumps.kwm2011-08-241-1/+1 * - Depend on the embedded wv2 instead of the one from ports.avilla2011-07-183-6/+24 * Update math/gsl to 1.15, and adjust PORTREVISIONbf2011-05-101-1/+2 * - Update KOffice to 2.3.3.avilla2011-04-133-13/+3 * - chase exiv2 library bumpbapt2011-04-121-1/+2 * - Update KOffice to 2.3.1.avilla2011-03-257-447/+1761 * - Get Rid MD5 supportmiwi2011-03-201-1/+0 * Chase after net/openldap24-server update.delphij2011-02-251-1/+1 * - Update graphics/libwpg to 0.2.0 releasefluffy2011-01-031-2/+2 * - Chase security/libksba shlib version bumpglarkin2010-12-161-1/+1 * - Fix plist when WITH_GTL is enabled.avilla2010-11-262-29/+36 * Chase poppler update.kwm2010-11-201-1/+1 * Mark INGNORE if qt-3.x is detected.makc2010-11-081-0/+4 * - Re-enable optional dependency on opengtl after the llvm update.avilla2010-09-071-4/+2 * Update KOffice to 2.2.2makc2010-08-28