aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile7
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-ngx_http_fancyindex_module.c34
3 files changed, 38 insertions, 9 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 5c80a06845db..08ebf920e3f3 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.62
+PORTVERSION= 0.7.63
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -25,6 +25,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
+ HTTP_IMAGE_FILTER_MODULE "Enable http_image_filter module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
HTTP_REALIP_MODULE "Enable http_realip module" off \
@@ -161,6 +162,10 @@ CONFIGURE_ARGS+=--with-http_flv_module
CONFIGURE_ARGS+=--with-http_gzip_static_module
.endif
+.if defined(WITH_HTTP_IMAGE_FILTER_MODULE)
+CONFIGURE_ARGS+=--with-http_image_filter_module
+.endif
+
.if defined(WITH_HTTP_MOGILEFS_MODULE)
NGINX_MOGILEFS_MODULE_VERSION= 1.0.2
MASTER_SITES+= http://www.grid.net.ru/nginx/download/:mogilefs
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index e86d2a56cc89..023bade2c1e7 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.7.62.tar.gz) = ab22f1b7f098a90d803a3abb94d23f7e
-SHA256 (nginx-0.7.62.tar.gz) = 60ee0e9f7f43a7387fec7752a47ff0d06166d2a37a6ad4cfe7aff77162378d2d
-SIZE (nginx-0.7.62.tar.gz) = 595995
+MD5 (nginx-0.7.63.tar.gz) = ddbdbeca5206dcc0cd7a4d9cbac00240
+SHA256 (nginx-0.7.63.tar.gz) = 06c1c61e1df3e4b56fbeab29eee66fe2b19bfe9eef20fdb484b2adfd8c1074c8
+SIZE (nginx-0.7.63.tar.gz) = 600683
MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
diff --git a/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c b/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c
index 0fce6e00699b..2b7512e39db6 100644
--- a/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c
+++ b/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c
@@ -1,6 +1,6 @@
--- ../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c.orig 2007-09-29 01:02:05.000000000 +0400
-+++ ../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c 2008-08-11 17:33:42.810249087 +0400
-@@ -290,7 +290,7 @@
++++ ../nginx-fancyindex-0.1_beta5/ngx_http_fancyindex_module.c 2009-06-03 16:41:36.000000000 +0400
+@@ -290,12 +290,12 @@
ngx_http_fancyindex_entry_t *entry;
off_t length;
@@ -9,16 +9,40 @@
u_char *filename, *last, scale;
ngx_tm_t tm;
ngx_array_t entries;
-@@ -426,7 +426,7 @@
+ ngx_time_t *tp;
+- ngx_uint_t i;
++ ngx_uint_t i, utf8;
+ ngx_int_t size;
+ ngx_str_t path;
+ ngx_str_t readme_path;
+@@ -355,6 +355,15 @@
+ filename = path.data;
+ filename[path.len] = '/';
+
++ if (r->headers_out.charset.len == 5
++ && ngx_strncasecmp(r->headers_out.charset.data, (u_char *) "utf-8", 5)
++ == 0)
++ {
++ utf8 = 1;
++ } else {
++ utf8 = 0;
++ }
++
+ /* Read directory entries and their associated information. */
+ for (;;) {
+ ngx_set_errno(0);
+@@ -425,8 +434,8 @@
+ entry->dir = ngx_de_is_dir(&dir);
entry->mtime = ngx_de_mtime(&dir);
entry->size = ngx_de_size(&dir);
- entry->utf_len = (r->utf8)
+- entry->utf_len = (r->utf8)
- ? ngx_utf_length(entry->name.data, entry->name.len)
++ entry->utf_len = utf8
+ ? ngx_utf8_length(entry->name.data, entry->name.len)
: len;
}
-@@ -563,12 +563,13 @@
+@@ -563,12 +572,13 @@
if (entry[i].name.len - len) {
if (len > NGX_HTTP_FANCYINDEX_NAME_LEN) {