aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mplayer-plugin/Makefile6
-rw-r--r--www/mplayer-plugin/files/patch-Source_plugin-threads.cpp14
2 files changed, 17 insertions, 3 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index fb50d26e4e51..aa97fcd4ce4f 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -7,18 +7,18 @@
PORTNAME= mplayerplug-in
PORTVERSION= 3.55
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
-MAINTAINER= marcus@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A Mozilla plugin for the MPlayer media player
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GECKO= firefox mozilla seamonkey libxul
+USE_GECKO= libxul firefox
USE_WEBPLUGINS= gecko*
WEBPLUGINS_FILES=mplayerplug-in.so mplayerplug-in.xpt mplayerplug-in-wmp.so \
mplayerplug-in-qt.so mplayerplug-in-rm.so \
diff --git a/www/mplayer-plugin/files/patch-Source_plugin-threads.cpp b/www/mplayer-plugin/files/patch-Source_plugin-threads.cpp
new file mode 100644
index 000000000000..5483d4b8237b
--- /dev/null
+++ b/www/mplayer-plugin/files/patch-Source_plugin-threads.cpp
@@ -0,0 +1,14 @@
+--- Source/plugin-threads.cpp.orig 2008-06-12 23:38:37.000000000 -0400
++++ Source/plugin-threads.cpp 2009-10-01 05:04:31.000000000 -0400
+@@ -14,8 +14,11 @@
+
+ static void sig_child(int signo)
+ {
+- // Not used, so commented out
+- // wait(NULL);
++ pid_t pid;
++ int status;
++
++ pid = wait(&status);
++ return;
+ }